AdWords
3.4K members online now
3.4K members online now
Improve your AdWords performance and boost your ROI, CTR, and Quality Score
Guide Me
star_border
Reply

i need some help my site

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

 need some help my site has been live for two month with no sales www.uniquegadgetsonline.com pls review and see if there anything wrong

1 Expert replyverified_user
Marked as Best Answer.
Solution
Accepted by topic author efe o
September 2015

Re: i need some help my site

Top Contributor
# 2
Top Contributor
Hi efe o,

Are you using AdWords to promote your site? Are you advertising specific products? Is the destination URL a page with a single product, the product you are advertising?



Or are you advertising gadgets and directing to the top page? It's usually better to advertise specific products than to send traffic to a directory or product listing page. Limit the number of choices and you usually will get a better conversion rate.

Best of Luck!

Pete

petebardo -- Deadhead doing AdWords

Re: i need some help my site

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
i am advertsing specific product. my universal portable charger, and smart bracelet both of which i created product video. since i started adverstising specific product i have better ctr but still no sales. i also noticed that people are clicking on my shopping cart maybe to se final cost i dnt know. my still no sales.

Re: i need some help my site

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭
i am advertsing specific product. my universal portable charger, and smart bracelet both of which i created product video. since i started adverstising specific product i have better ctr but still no sales. i also noticed that people are clicking on my shopping cart maybe to se final cost i dnt know. my still no sales. .
.

website review

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

i am advertsing specific product. my universal portable charger, and smart bracelet both of which i created product video. since i started adverstising specific product i have better ctr but still no sales. i also noticed that people are clicking on my shopping cart maybe to se final cost i dnt know. my still no sales. .
.www.uniquegadgetsonline.com

Re: i need some help my site

Top Contributor
# 6
Top Contributor
Hi Efe o,

There's something wrong with your site. It's missing the character set and language meta tags. The missing character set causes some characters on your page to show � instead of the character. That may be affecting your trust factor. People, including myself, will think "If they can't make a decent web site, why would I trust them with my order?"

Are you composing with a Mac? It kind of looks that way. I would guess you have apostrophes instead of the ASCII single quote, and that you're using some sort of dash that browsers don't honor. I'd take a look at those thing and see if you can get them straightened out.

I'm looking at he smart bracelet page. There is an empty select box. I can't tell what that's supposed to be, a color selector or a quantity selector.

When I place the item in the shopping cart, there's no indication the site will be secure (https). That could be a stopping point. Then it goes offsite, to Yahoo I assume, to complete the purchase. Any of these things could be a stopping point for a prosective buyer.

Pete
petebardo -- Deadhead doing AdWords

Re: i need some help my site

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭
where do i find the missing character set and lanquage meta tags. And i do use mac computer and how does mac effect my webpage not sure what you meant?

Re: i need some help my site

Top Contributor
# 8
Top Contributor
Hi efe o,

Try this in the head of your documents:

<meta http-equiv="Content-Language" content="EN">
<meta name="language" content="English">
<meta http-equiv="Content-Type" content="text/html;charset=utf-8" >

Macs use a single quote instead of an apostrophe. For double-quotes, Macs have an open quote and a close quote. Those aren't standard for all character sets for most browsers, and not for the default character set either. Declare the character set as utf-8 to take care of most of the problems.

For the dash, you may need to replace those with a double hyphen (--) as the dash is not part of the default character set. It looked like you may have some sort of bullet character on some of them. You should replace those with HTML encoded characters. ( A bullet is &bull; ).

Here's a page that lists many of the HTML characters, including a dash, open and close quotes and a bunch more:

http://www.zytrax.com/tech/web/entities.html

I don't know if this will help, but it's a good thing to do anyway.

Pete
petebardo -- Deadhead doing AdWords