AdWords
1.7K members online now
1.7K members online now
For questions related to Google Shopping and Merchant Center. Learn to optimize your Shopping ads
Guide Me
star_border
Reply

image errors increase exponentially- what's the issue here?

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

Our product feed always had a small percentage of 'image errors'- 2-3%. Recently we noticed number Increasing by 100% from previous day. Yesterday I realized that image urls all of a sudden were not resolving. Developer addressed the issue and image urls resolve as expected now. I pulled uploaded new feed yesterday 5-16-14. This morning number of image errors increased from 20% to 40%.

1. I checked urls within the feed- images resolve- I'm attaching the feed.

2. I checked urls within "image errors" sample in Merchant center- they resolve.

 

Why image errors increase by 100% daily from previous day?

here's our robots.txt file:

User-agent: *
disallow: /catalogsearch
disallow: /*.html?multi=true
User-agent: Googlebot-Image
allow:/media/catalog/product/
Sitemap: http://www.equipatron.com/parts.xml
Sitemap: http://www.equipatron.com/small_engines.xml
Sitemap: http://www.equipatron.com/forestry.xml
Sitemap: http://www.equipatron.com/power_equipment.xml
Sitemap: http://www.equipatron.com/industrial_equipment.xml
Sitemap: http://www.equipatron.com/accessories.xml
Sitemap: http://www.equipatron.com/brands.xml
Sitemap: http://www.equipatron.com/blog.xml
Sitemap: http://www.equipatron.com/other.xml

 I have a copy of product feed, but I don't see how to attach it here.

Example of image urls:

AR-240 image url:

http://www.equipatron.com/media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/a/r/a...

 

ZAM-C1U-K52 image url:

http://www.equipatron.com/media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/z/a/z...

Merchant dashboard- image errors 5-17-14.jpg

Data Quality- Image errors-url resolve on open 5-17-14.jpg

Re: image errors increase exponentially- what's the issue here?

Top Contributor Alumni
# 2
Top Contributor Alumni

Hi Olga

 

What did your developer change and what was the initial problem?

 

Images can take time to crawl, so it may be a case of waiting a few days for them to become available.

 

Tom Wilson
Freelance Adwords & Google Shopping Consultant

If you find this or another response helpful within the forum "please accept as solution" to further assist and direct others.

Re: image errors increase exponentially- what's the issue here?

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
It's not clear what was done to make urls work. The information we have is
that image url issue was related to the back-end image cache being flushed,
which disrupts url paths (We use Magento Enterprise).

I've been sampling image urls since Friday evening and they resolve as
expected. However percentage of "invalid images" is still growing daily.
After Friday 'fix' we had 20% and today it's up to 57%.

I'm wondering if there's another issue with crawling images. Where I can
get help with this?
I emailed AdWords Support and will call 866 number. Is there anything else
I can be doing to get to the bottom of this?

Thank you

Re: image errors increase exponentially- what's the issue here?

Top Contributor Alumni
# 4
Top Contributor Alumni

Hi Olga, 

 

Yes there does appear to be another problem here as its would appear not to have been re-indexed yet. 

 

Example1

Example2

 

The only thing i think it might be is the second is too large 1500x1500 but you'd need to confirm before they were smaller. 

 

See the bottom section here: https://support.google.com/merchants/answer/160640?hl=en

 

I'd suggest yes to contact Google directly and i'll also escalate this thread. 

 

Tom Wilson
Freelance Adwords & Google Shopping Consultant

If you find this or another response helpful within the forum "please accept as solution" to further assist and direct others.

 

 

Re: image errors increase exponentially- what's the issue here?

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Tom,
I'm working with AdWords support on troubleshooting. If someone else is having similar issue, support suggested I add 4 lines into robots.tx file:

User-agent: Googlebot
Disallow:

User-agent: Googlebot-image
Disallow:
Re-upload the feed and wait for it to be re-crawled within 48 hours.
Thanks for your suggestions. I'll close this thread when solution is determined