AdWords
3.8K members online now
3.8K members online now
For questions related to Google Shopping and Merchant Center. Learn to optimize your Shopping ads
Guide Me
star_border
Reply

Missing microdata for condition

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

"Missing microdata for condition" I am getting this error for my Google Shopping listings at Diagnostics -> Current issues -Items and have been for sometime now.

However when I test my product pages on the Google Structured Data Testing Tool (https://developers.google.com/structured-data/testing-tool/) it states that itemCondition: http://schema.org/NewCondition is present.

Here is a url you can use to test: http://www.eflbooks.co.uk/book.php?isbn=9780521180276

itemCondition is the last property displayed, "condition" and "Condition" as opposed to "itemCondition" are not valid properties.

 

2 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author James G
September 2015

Re: Missing microdata for condition

[ Edited ]
Top Contributor
# 2
Top Contributor


what is accepted via the testing-tool

is not necessarily what is required for
the automatic-item-updates feature.

 

for that specific link landing-page, try the following:
<meta itemprop="itemCondition" content="http://schema.org/NewCondition" />

 

also, itemtype product seems to be missing:

<div itemtype="http://schema.org/Product" itemscope>


also, price should be digits only.

 

then, resubmit the data (feed).

also, the re-crawl and update or removal
of any such messages within the account
may take on the order of several weeks.

otherwise, a support specialist may be contacted directly.
https://support.google.com/merchants/contactflow

 

see also

https://support.google.com/merchants#topic=3404778

 

View solution in original post

Marked as Best Answer.
Solution
Accepted by topic author James G
September 2015

Re: Missing microdata for condition

[ Edited ]
Top Contributor
# 2
Top Contributor


what is accepted via the testing-tool

is not necessarily what is required for
the automatic-item-updates feature.

 

for that specific link landing-page, try the following:
<meta itemprop="itemCondition" content="http://schema.org/NewCondition" />

 

also, itemtype product seems to be missing:

<div itemtype="http://schema.org/Product" itemscope>


also, price should be digits only.

 

then, resubmit the data (feed).

also, the re-crawl and update or removal
of any such messages within the account
may take on the order of several weeks.

otherwise, a support specialist may be contacted directly.
https://support.google.com/merchants/contactflow

 

see also

https://support.google.com/merchants#topic=3404778

 

Re: Missing microdata for condition

Follower ✭ ☆ ☆
# 3
Follower ✭ ☆ ☆
"also, the re-crawl and update or removal of any such messages within the account may take on the order of several weeks."

Or, several months, like mine. And I still have them. And yes, I have contacted Google. Apparently, all is OK. Still a bit weird though.

Re: Missing microdata for condition

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭
Thank you I've implemented your suggestions, so will wait and see if that fixes the problem.

Re: Missing microdata for condition

Follower ✭ ✭ ✭
# 5
Follower ✭ ✭ ✭
A final way of dealing with this is to disable automated updating. I suggest keeping it as the data quality will improve. But currently there is no requirement to have this enabled.

Re: Missing microdata for condition

[ Edited ]
Top Contributor
# 6
Top Contributor


of course, the automatic-item-update feature is not required
and may be disabled at any time within the account settings.

however, an issue with simply disabling the feature
is that a mismatch between the submitted data and
the link landing-page crawled data can also trigger
a disapproval or suspension -- for example, if there
are multiple prices on the page.

simply disabling the feature may then trigger a
different disapproval or suspension -- be certain
to verify the landing-page conforms to all rules
and policies and can be easily and accurately
crawled, before considering such an action.

or, a support specialist may be contacted directly.

Re: Missing microdata for condition

Follower ✭ ☆ ☆
# 7
Follower ✭ ☆ ☆
Hey Celebird,

I have: <meta itemprop="itemCondition" content="http://schema.org/NewCondition" /> on my pages already and have done for some time.

But, today I have a new "Missing microdata for condition" dated 16 June 2015.

Google's testing tool tells me all is OK too. Yes, I know, cannot rely on it, for some reason.

Also, you say "of course, the automatic-item-update feature is not required and may be disabled at any time".

Initially, I never actually turned on the feature, but, still had these errors. It's almost like it was turned on and then off. But again, I never enabled this feature. No one else has access to this account.

This is getting really weird. It's almost like this stuff is, well, broken.

Any ideas, before I contact Google?

Thanks.

Re: Missing microdata for condition

Follower ✭ ☆ ☆
# 8
Follower ✭ ☆ ☆
Celebird, not to worry. Haven't fixed it, but, going to try a couple of things. Thanks.

Re: Missing microdata for condition

[ Edited ]
Top Contributor
# 9
Top Contributor


first, thank you for the update.

the (optional) feature is enabled by default
and the website will be checked by default,
unless the feature is disabled.

the reply was mainly to indicate that disabling the
feature has (possibly unwanted) consequences --
depending on landing-page details and other factors.

otherwise, the itemscope seemed to be missing;
otherwise, a support specialist may be contacted for guidance.

 

Re: Missing microdata for condition

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭
Hello , I have the same issue , I have also had a massive drop in click through's since this has happened - has any body had the same issue ? and is it worth contacting Google to hurry up it's crawl to get rid of these errors or is it just a waiting game ?