AdWords
4.6K members online now
4.6K members online now
For questions related to Google Shopping and Merchant Center. Learn to optimize your Shopping ads
Guide Me
star_border
Reply

Merchant Center shows errors - Testing Tool shows no errors

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

We added the schema for condition on all our items after getting the error message in the Merchant Center over a week ago. ie: <link itemprop="itemCondition" href="http://schema.org/NewCondition"/>

 

We still get the error message for no condition in Merchant Center for about 50% of our items. The Testing Tool shows that the condition is on the pages.

2 Expert replyverified_user

Re: Merchant Center shows errors - Testing Tool shows no errors

[ Edited ]
Top Contributor
# 2
Top Contributor


generally, try loading the page in few browsers to be certain that
the page loads quickly and completely without any errors -- and
check the server's log files to be certain the server responds
properly and can keep pace with all google's crawl requests.

also, be certain that the microdata, any visible link landing-page
information, and the submitted data, all match exactly at all times.

also, be certain that the condition matches the physical item --
for example, vintage items must usually be submitted as used.

 

also, if any variants are submitted be certain that proper identical

item_group_id and proper unique variant attributes and values

are submitted and the link landing-page and microdata adhere

to all google's merchant-center variant-related policies.

 

also, regardless of the testing-tool results,
try the following on a few flagged pages:
<meta itemprop="itemCondition" itemtype="http://schema.org/OfferItemCondition" content="http://schema.org/NewCondition"/>New

also, be certain id values never ever change for any item.

otherwise, the notifications under the diagnostics-tab
may take on the order of several weeks to be updated.

otherwise, unfortunately forum members cannot look into
any submitted (feed) data or accounts; however, a support
specialist may be contacted directly.

Re: Merchant Center shows errors - Testing Tool shows no errors

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Our pages load just fine. All micro data matches that on the landing page data, as shown in the Google Testing Tool in WMT.

Merchant Center gives new notifications everyday of the items with no condition errors, even though Google WMT Testing Tool shows the condition is good.

All items have identical html
<link itemprop="itemCondition" href="http://schema.org/NewCondition" />NEW</span>
According to the Merchant Center 53% of our products show errors.

Merchant Center only shows 50 of the 955 shown as errors.
So what items is Merchant Center seeing as GOOD?

Why can’t all items good and errors be shown and downloaded?

Re: Merchant Center shows errors - Testing Tool shows no errors

Follower ✭ ✭ ✭
# 4
Follower ✭ ✭ ✭
Hi the merchant diagnostics has a delay in removing errors and warnings. It is quick in telling you, you have an error but slow in removing them. Plus it has a 2 day delay.

Removing in this case the condition error can take a while as it needs to check each page. And Google does not crawl your pages every single day for every single page.

If you have added it, it can take up to a month before you slowly see them disappear.

Be cautious, if it's an error you need to make sure they are fixed asap within 7 days, warnings are merely there to improve you data quality and has not effect on account suspensions.

So just wait till they are gone if you are sure you have done it correctly. Also I recommend using the meta tag instead of a link as it's defined at Google's documentation. https://support.google.com/merchants/answer/6069143?hl=en

The link should be fine, but the link element is not used in the examples.

Re: Merchant Center shows errors - Testing Tool shows no errors

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
After receiving your reply I revised the condition on half my items as suggested to:

<meta itemprop="itemCondition" itemtype="http://schema.org/OfferItemCondition" content="http://schema.org/NewCondition"/>

The Merchant Center shows that it crawled pages the evening of May 27 and shows errors for no condition included in the half changed, and on May 28th the WMT shows that it does have the condition. Merchant Center no condition errors are increasing every day, shows only 50 items and there is no way to export the list.

Re: Merchant Center shows errors - Testing Tool shows no errors

Follower ✭ ✭ ✭
# 6
Follower ✭ ✭ ✭
You can export the list. It's in the right corner under the diagnosis graph.

Re: Merchant Center shows errors - Testing Tool shows no errors

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭
Regarding the delay of the error being removed, I still get the errors daily. This started in May and it is now August. Our products have the meta tag condition as recommended by Google, the Testing Tool shows the products has the condition and these items are still on the error report. What good is an error report if it is not accurate. I called and talked to a person at Google Help and they agreed we have the microdata for condiation, but not to worry that the error is not one for suspension. Again, what good is the error report then?

Re: Merchant Center shows errors - Testing Tool shows no errors

[ Edited ]
Top Contributor
# 8
Top Contributor


most messages under the diagnostics-tab are historic overviews --
meant to help analyze the root-causes of issues; not necessarily
a real-time or accurate current view.

if all the issues have been fixed then, the messages
may be removed in a few months or so after google
re-crawls the website a few times and updates the
account's diagnostics information.

always check the diagnostics-tab sampled-at dates
against the individual item's last-update-on date --
by clicking on the affected-items link and then,
on the item's title under the example-column.

generally, if the sampled-at dates are recent and coincide with the
last-update-on dates then, the issue is usually not resolved; however,
if the sampled-at dates are older and do not coincide at all with the link
landing-page changes or the last-update-on date then, the messages
are likely simply historic for helping to track issues over time and have
not been updated or removed.

Re: Merchant Center shows errors - Testing Tool shows no errors

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭
The sampled-at dates are recent, today I got a dozen, yesterday over 100 sampled items, many items are sampled every day. On May 30th, (see above reply to Emmanuel) half of our items (A-L) were updated with the Google recommendation: <meta itemprop="itemCondition" itemtype="http://schema.org/OfferItemCondition" content="http://schema.org/NewCondition"/>

Yet these items still come up on the Diagnostics as No Condition when the Testing Tool shows the Condition is there! Today this item showed on the error report that has condtion according to the Testing Tool:
http://www.alpineaccessories.com/Descente-Mens-Orion-Ski-Jacket/productinfo/D58675/
If the above item had <meta itemprop="itemCondition" itemtype="http://schema.org/OfferItemCondition" content="http://schema.org/NewCondition"/> added on May 30th, why does it still show up on the error report?

Re: Merchant Center shows errors - Testing Tool shows no errors

Top Contributor
# 10
Top Contributor

what is the link url being submitted of an item being flagged?

are all attributes being processed and seen when the item's
title is clicked within the merchant-center; especially the link
and condition attributes and values?

what exactly are all the flagged messages for the example item?

unfortunately, forum members cannot look into feeds or accounts --
we can mainly offer suggestions based on the information posted
here in the public forums.