Optimize
2.1K members online now
2.1K members online now
Discover how to select who is eligible to be in your experiment, and when they’re served experiment variations.
Guide Me
star_border
Reply
Highlighted

Optimize not showing variations

cdb
Visitor ✭ ✭ ✭
# 1
cdb
Visitor ✭ ✭ ✭

Hi,

 

I have set up an experiment using Optimize. I am using Javascript events to trigger the changes in my code. However when I start the experiment Optimize only displays the original even though I have set it to only be served 1% of the time. I never see the variants. Has this happened to anyone else?

 

Thanks.

1 Expert replyverified_user

Optimize not showing variations

Follower ✭ ✭ ✭
# 2
Follower ✭ ✭ ✭

It'd be great to hear what Google would recommend in this situation. I have also experienced something similar. I'm at the point where I'm assuming this is some kind of bug. I also made changes with JavaScript knowing that the code is perfect and worked in preview, but the reporting is definitely telling a very different story.

Optimize not showing variations

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Same here, I set the experiment variant to 99.9%, but cannot get it to be displayed no matter what. Works fine when I go to edit or setup the changes, but does not in either: the preview or when I normally enter the website. Can somebody advice ?

 

I've tried w/ couple of different experiments (to check if it's not the problem of the one I'm currently running), checked the code and still nothing ... Very frustrating indeed.

Optimize not showing variations

Follower ✭ ✭ ✭
# 4
Follower ✭ ✭ ✭

Can someone from Google please respond to this thread? It has been a month now. I'm wondering if it's from your implementation of the Optimize snippet. We experienced a lack of stability in experiments showing even with following the documentation provided by Google. Check that the snippet is on the page, and if it is, check your cookies looking for _gaexp to see if you've been bucketed into the experiment at all. If you are, check that the cookie's value matches your experiment number and variation index.

Optimize not showing variations

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Hey - I will paste this reply to other users asking the same.

 

I had a similar issue.  I'd reload my broswer window, and even try different broswers - I kept only seeing my original.


Then I tried "incognito / private" windows in various broswers (Chrome, Safari, Firefox, Opera) and I did in fact start to see the variants fire off & display in an alternating fashion (I have it set to 50/50)

You may want to try that.  I don't know the scope of your issue - code , etc but this showed me that in fact Google Optimize is serving the variants.

 

Good luck! - AR

Optimize not showing variations

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

Hey - I will paste this reply to other users asking the same.

 

I had a similar issue.  I'd reload my broswer window, and even try different broswers - I kept only seeing my original.


Then I tried "incognito / private" windows in various broswers (Chrome, Safari, Firefox, Opera) and I did in fact start to see the variants fire off & display in an alternating fashion (I have it set to 50/50)

You may want to try that.  I don't know the scope of your issue - code , etc but this showed me that in fact Google Optimize is serving the variants.

 

Good luck! - AR

Optimize not showing variations

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

Hey - I will paste this reply to other users asking the same.

 

I had a similar issue.  I'd reload my broswer window, and even try different broswers - I kept only seeing my original.


Then I tried "incognito / private" windows in various broswers (Chrome, Safari, Firefox, Opera) and I did in fact start to see the variants fire off & display in an alternating fashion (I have it set to 50/50)

You may want to try that.  I don't know the scope of your issue - code , etc but this showed me that in fact Google Optimize is serving the variants.

 

Good luck! - AR

Optimize not showing variations

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭

Did someone solve this? I get a similar problem.

 

I see that the cookie is set for the variant, but do not see the variant. It only seem to work in ”new” browsers  or incognito mode.

 

Is it because I have previewed the test before and it’s because of cache? How do I know it’s not affecting the visitors in the test as well? Could users who’ve seen the variant before (or in a previous test) see the original the next time, even though they are reported to have seen the variant?

Optimize not showing variations

Google Employee
# 9
Google Employee

Hi Elin,

 

If you are still experiencing this issue, and are comfortable sharing your container public ID (GTM-XXXXX), we will take a look.

Optimize not showing variations

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭

I've got the same problem. I've moved everything to Google Tag Manager, but it doesn't help.

Google Optimize verifies that everything is installed correctly, Google Analytics works, Google Tag manager verifies that everything is working, Preview mode works... But once I try it in the browser it does not work, or if i try to trigger it on a custom even ("optimize.activate")

Container code:

GTM-WMB2XL4