Optimize
1.6K members online now
1.6K members online now
Everything you need to know about setting up Optimize including creating your account and container, linking to Google Analytics and how to tag your site.
Guide Me
star_border
Reply

Page hiding snippet not stopping 'flicker'

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi guys, we're on the beta for the free version of Optimize and we're having a lot of grief getting the page hiding snippet to load and stop the 'flicker'. We're using GTM to install the Optimize code and the page hiding snippet is hard coded. Despite us installing the page hiding snippet directly after the opening tag, it doesn't work properly and the flicker is still there. Can you help us figure where we're going wrong?

1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by Jason O (Community Manager)
December 2016

Page hiding snippet not stopping 'flicker'

Google Employee
# 3
Google Employee

A common mistake is the one mentioned in help:

 

If you’re using the recommended Page hiding snippet with Tag Manager, populate it with your Tag Manager container ID, not your Optimize container ID.

 

Is the page public? Could you send the URL?

View solution in original post

Page hiding snippet not stopping 'flicker'

Visitor ✭ ✭ ✭
# 2
Visitor ✭ ✭ ✭

Same problem with us. Significant flicker when using hiding snippet makes this unusable.  Please help!

Marked as Best Answer.
Solution
Accepted by Jason O (Community Manager)
December 2016

Page hiding snippet not stopping 'flicker'

Google Employee
# 3
Google Employee

A common mistake is the one mentioned in help:

 

If you’re using the recommended Page hiding snippet with Tag Manager, populate it with your Tag Manager container ID, not your Optimize container ID.

 

Is the page public? Could you send the URL?

Page hiding snippet not stopping 'flicker'

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Tx for the reply Dimitris.  I actually was adding the code manually.  I found that when I didn't use the page hiding snippet, the flicker went away.  

Page hiding snippet not stopping 'flicker'

Follower ✭ ☆ ☆
# 5
Follower ✭ ☆ ☆

Hello.

 

Same thing here.  I actually just removed my account and container all together in Google Optimize and I am still getting page flicker.  Anyone?  Link.

Page hiding snippet not stopping 'flicker'

Google Employee
# 6
Google Employee

I think that they mistake that you are doing is that you have been adding both the page hiding snippet and the Optimize snippet with a GTM arbitrary HTML tag.

 

The page hiding snippet can't be installed using GTM or any other asynchronous script, since its the asynchronous nature of those scripts that are causing the flicker.

 

Both GTM and Optimize are asynchronous which means that they allow the page to load and parse itself until they load. This is done in order to avoid affecting the performance of your site.

 

But this also means that it may be possible that the page will be also displayed to the user before those scripts have the chance to run. This is what the page hiding snippet was designed to help - so it has to be added on the page in the same way as the original GTM snippet.

 

See for more details:

https://support.google.com/360suite/optimize/answer/7100284?hl=en

 

Page hiding snippet not stopping 'flicker'

Follower ✭ ☆ ☆
# 7
Follower ✭ ☆ ☆

Thanks!  Yea I just removed it all together and the flicker went away, seen here.  I will tackle this later.