Optimize
5.8K members online now
5.8K members online now
Everything you need to know about setting up Optimize including creating your account and container, linking to Google Analytics and how to tag your site.
Guide Me
star_border
Reply
Highlighted

Page Hiding Snippet Configuration Error when Deploying Manually but GTM is Present

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi guys,

 

An issue arises when I tried installing GO code via Google Tag Manager - then deployed the page hiding snippet as per instructions, it worked but the diagnostics tool required in very strong language to deploy the snippet manually. I added the code manually, paused the hiding snippet tag in GTM and I am still getting an error indicating that the diagnostic tool thinks I am loading the snippet via GTM.  

 

  1. Is it just a case of the diagnostics tool looking at an older version of the site due to caching issues?
  2. Do I need to not only pause but delete the page hiding snippet tag in Google Tag Manager for the error to go away?

(I of course added the GTM container ID when deploying via GTM and the Optimize container ID when deploying manually)

 

Update: I deleted the tag but the error still persists. Seems like a false positive or does the error appear when implementing GO main code in GTM and the page-hiding snippet manually in which case  am I stuck in an endless loop of errors where one error requires me to implement the snippet in GTM while the other prohibits it?

 

As an user, it is quite frustrating - I am not doing anything out of the ordinary, following the instructions to the letter and I just want to get rid of errors, do a quick experiment and be about my day. I have very many tasks and this is taking a bit too much of my time. 

 

1 Expert replyverified_user

Page Hiding Snippet Configuration Error when Deploying Manually but GTM is Present

Google Employee
# 2
Google Employee

Hi Robert,

 

Did you by any chance reformat the page-hiding snippet? Also if your Optimize container is loaded via the GTM Optimize tag, the page hiding snippet should use the GTM container ID instead of the Optimize container ID. Would you mind sharing your Optimize container ID if you still have the problem?

 

Thanks!

Page Hiding Snippet Configuration Error when Deploying Manually but GTM is Present

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi guys, no problem.

1. I did not reformat the page-hiding snippet. Plain copy+paste.
2. Yes, I know about container ID's - and I acted accordingly.

3. The Optimize container ID is GTM-WSQV247