Optimize
4.9K members online now
4.9K members online now
Everything you need to know about setting up Optimize including creating your account and container, linking to Google Analytics and how to tag your site.
Guide Me
star_border
Reply

A/B test not receiving any visits but the page is on analytics.

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

 

I made one variant for one of the website content pages. But both versions on Google Optimize show no visits but on Google Analytics it is tracking for visits and goal conversion correctly when tested in real time. I think there is an issue with the code. Can someone please advice on this?

 

Thank you.

A/B test not receiving any visits but the page is on analytics.

Follower ✭ ✭ ✭
# 2
Follower ✭ ✭ ✭

There's a possibly there might be code error, but I'd keep in mind that it takes data up to 12 hours to propagate from GA into Optimize.

A/B test not receiving any visits but the page is on analytics.

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hey Japneet and Robert, I have the same problem.

 

I have a test that has been running for more than 4 days and the Google Optimize report says that Variant 1 has had 1 view in those 4 days and the original has had 0 views. However, when I go to GA, it shows that page has had at least 37 sessions in the same time period.

 

I'm pretty sure I installed the code correctly (added the single GO code in the right area of the GA code and then added flickering code right above the GA code).

 

Thanks for your help.

A/B test not receiving any visits but the page is on analytics.

Follower ✭ ✭ ✭
# 4
Follower ✭ ✭ ✭

Hey, I would check your distribution of weight for each variant. Analytics will also always have different numbers from Optimize. Have you also tried the process of opening the page being tested in a blank incognito window, closing out of the window, and then repeating the process again? Out of all the times you do this, you should be bucketed into your variant if all is working as expected, and fits with the weight distribution you've allocated.

Re: A/B test not receiving any visits but the page is on analytics.

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

By distribution of weight, do you mean the % going to each variation? That I have left at 50/50 to try and get some data as quick as possible.

 

I just put in the page into firefox, a private firefox window, chrome and a private chrome window and all came back with the original version of the page. None returned the variant.

 

This is the page. If you go here and see "#1 Security Experts in Phoenix" then you're seeing the original. 

https://knoxsecurity.us/security-systems/

 

Thanks

A/B test not receiving any visits but the page is on analytics.

Follower ✭ ✭ ✭
# 6
Follower ✭ ✭ ✭

Just took a look at the page, as with another thread I just addressed. If you open up console (press cmd + option + i on a Mac in Google Chrome) then click on the application tab, you'll see that the _gaexp cookie does not exist which should exist when you're running an experiment. I see that Optimize is installed on the page in the head so your issue may lie in the actual experiment configuration itself. Otherwise, you might have an issue with how the snippet for Optimize has been implemented. In my case, GTM comes after my Optimize scripts, but I see the GTM script called asynchronously above the head where you've placed the Optimize scripts.  

Re: A/B test not receiving any visits but the page is on analytics.

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

Hey Robert, thanks for the help.

 

I've put the GTM code under both GA and GO code now to see if that will make a difference. I also just realized I still had an old plugin inserting a second GTM code, which I have now removed.

 

You mentioned the "issue may lie in the actual experiment configuration itself" or "might have an issue with how the snippet for Optimize has been implemented." How could I debug those issues?

 

Where should _gaexp be sitting? In Dev Tools --> Application, I see a few sections of folders like Storage, Cache, Frames, etc. Where in there would the _gaexp be?

 

Thanks for all your help.

A/B test not receiving any visits but the page is on analytics.

Follower ✭ ✭ ✭
# 8
Follower ✭ ✭ ✭

Anytime, for what I mentioned, you need to check the settings of your experiment, and preview the variant to make sure the changes you made are actually being made. For the snippet, depending how you deploy it, I would put console logs into either GTM, GO, or both. You'll be able to see what order things fire in and whether GO is running at all.

 

For the _gaexp, it will be under Storage > Cookies. In there, you should click on the first cookie to see if that includes _gaexp.

Re: A/B test not receiving any visits but the page is on analytics.

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

Great. I'll look at this a bit over the next few days and try to work it out.

 

Thanks for all your help Robert.

A/B test not receiving any visits but the page is on analytics.

Follower ✭ ✭ ✭
# 10
Follower ✭ ✭ ✭

Anytime and hope you get everything sorted.