AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

Optimize
1.9K members online now
1.9K members online now
Learn how to create your first experiment and get tips on creating A/B, redirect, and multivariate tests.
Guide Me
star_border
Reply

Testing the same element on every page doesn't work

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hello, I am testing the same element on every page. I set editor page as homepagename.co.nz/.*

 

My experiment doesnt show anywhere on the site. 

 

Can you help me out here?

 

I did get the 404 Error when editing the element in optimize but thought I'll go for it anyway.

1 Expert replyverified_user

Testing the same element on every page doesn't work

Follower ✭ ✭ ✭
# 2
Follower ✭ ✭ ✭

Assuming the URL targeting is correct, you would need to look at the change you made in the variant. Assuming you injected JavaScript in since you're element's not available on the page, you should test when your JavaScript fires. Try targeting the head tag instead of whatever you're currently targeting, and grab the element from there. Otherwise, you should also check to see whether your website is a SPA (e.g. built off ReactJS, AngularJS, etc.), and make modifications accordingly.

Testing the same element on every page doesn't work

Google Employee
# 3
Google Employee

Hi

 

Use just one representative page (anyone will do) as your editor page, so that you can use the editor.

 

Then use the targeting rules under (Targeting tab) to change the scope of your experiment using a url regex match or other types of rules - like match for just your site's domain.

 

See: https://support.google.com/360suite/optimize/answer/6283420?hl=en

 

Use the Rule checker functionality in the targeting dialog to make sure that your experiment will match the urls that you want. Also don't forget to use the preview functionality to test your variations before starting your experiment.

 

You can actually navigate your whole site on the preview tab and test that it works.