Optimize
4.7K members online now
4.7K members online now
Learn how to create your first experiment and get tips on creating A/B, redirect, and multivariate tests.
Guide Me
star_border
Reply
Highlighted

I have 3 redirect experiments running with URL formats, and none are showing any active user info

[ Edited ]
M W
Visitor ✭ ✭ ✭
# 1
M W
Visitor ✭ ✭ ✭

I am writing this on behalf of my company's account property.

We have 3 experiments running in Google Optimize with different URL structures and none are registering any active user or session data.

We are using different URL structures after reading other users having problems with their servers' doing other redirects that strip parameters out. So we are trying to see which format works, as our site is built on an IBM Notes and Domino setup and thus creates URLs that may or may not be problematic.

 

I believe we have at least one of the URL types set correctly. I am able to visit the original page and the redirects happen. I see the variant. I have sent the link to others outside my IP and the redirects happen and some see the original and some see the variant. 

Why is there no data coming in?

 

Thank you.

2 Expert replyverified_user

I have 3 redirect experiments running with URL formats, and none are showing any active user info

Google Employee
# 2
Google Employee

Hi

 

Are your redirect targets configured with Google Analytics, and are they sending data to the same property that is linked with your container?

 

An easy way to  check is by using Chrome developer tools ("Menu > More Options"), open the "Network tab" and filter for requests that contain "collect".

 

Are there any requests, and is the UA-XXXX property in the parameters the same as the one that you can see in your container experiments list page?

I have 3 redirect experiments running with URL formats, and none are showing any active user info

M W
Visitor ✭ ✭ ✭
# 3
M W
Visitor ✭ ✭ ✭

Oh sorry! Thanks for the reply. I didn't notice I had received one.

I didn't configure anything in Google Analytics, as in I made the redirects on our server.

I do find one request with "collect" and I find one of the redirects I set up within the params.

And the property shown is the same as the one in the Optimize container.

 

I have 3 redirect experiments running with URL formats, and none are showing any active user info

M W
Visitor ✭ ✭ ✭
# 4
M W
Visitor ✭ ✭ ✭

What could this mean then? 

I am not sure what could be done to get an experiment to work.

I have 3 redirect experiments running with URL formats, and none are showing any active user info

Google Employee
# 5
Google Employee

 

So are the following true?

 

1) The URLs that you see after the redirect happens, contain a gaexp parameter (this is added by Optimize). One possibility is that your site does a server side redirect and removes this parameter.

 

2) The redirected pages have GA setup with the same property as your Optimize container (otherwise your data maybe going to the wrong property).

 

3) The redirected pages do sent a "collect" hit and this contains somewhere in the request in the http request headers (in referrer) the gaexp parameter. If all is correct, this should contain the experiment id that you may see in the sidenav panel of your experiment details page.

 

If all of these are true and you still can't figure out what is happening, could you share your container ID?