Optimize
4.2K members online now
4.2K members online now
Learn how to create your first experiment and get tips on creating A/B, redirect, and multivariate tests.
Guide Me
star_border
Reply

Google Optimize changes utm parameters

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

When running tests, we are sending traffic with utm parameters to Google optimize which is then changing those parameters to it's own tracking code. We are seeing lower results for our campaigns since the test started and wanted to know if this change in utm parameters is something that can be adjusted.

1 Expert replyverified_user

Google Optimize changes utm parameters

Google Employee
# 2
Google Employee

Hey Harrison,

 

Just to make sure we're clear, can you share what the parameters were before and after the Optimize test?  Thanks!


Jon

Google Optimize changes utm parameters

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Before:

http://www.dentalplans.com/lp-ppc/dentalinsurance?&affid=59864&utm_medium=CPC&utm_source=google&utm_...

 

changes to:

http://www.dentalplans.com/lp-ppc/dentalinsurance?utm_expid=.MbzYVXpbSoaYqshEZ2deUg.0&utm_referrer=h...

 

We are also noticing that our data no longer matches in Adwords with google analytics since we started this split test.

Google Optimize changes utm parameters

Google Employee
# 4
Google Employee

Thanks!  We're taking a look.  Re: AdWords data, can you describe a bit more what discrepancy you're seeing?

Google Optimize changes utm parameters

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

We believe that the stripping of the UTM parameters are pushing all of our paid traffic in GA into Organic. 

 

On our site anything in the /lp-ppc/ folder is blocked on robots.txt. So it is impossible for it to be organic. Here is a screenshot showing this: https://www.screencast.com/t/DSSOoWMrk

 

Here is a screenshot of the source / medium in GA: https://www.screencast.com/t/EB0F1o7a

 

As you can see all of our landing pages for PPC that are part of our google optimize split test are going to organic and not Paid search, which is throwing off the data.

 

Google Optimize changes utm parameters

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

We had to pause this test due to the tracking issues for now. 

 

For your reference it was experiment: https://optimize.google.com/optimize/home/#/accounts/948802827/containers/6086459/experiments/19

Google Optimize changes utm parameters

Google Employee
# 7
Google Employee

Hey Harrison,

 

In digging a bit more, the issue is that you've got an ampersand (&) after your question mark in the "before" URL, which is causing the issue - most URLs would only include the ampersand after the first parameter.  You can try removing that, which should help.  That said, we'll also make an update soon (probably within a week or two) to be able to better deal with a situation like that.  Thanks!

 

Jon

Google Optimize changes utm parameters

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭

We will have to go through all of our urls to try and correct that and we will see how it goes. Can we keep this thread open until we confirm or you add that update?

Google Optimize changes utm parameters

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

Do you have an ETA on when your change will be made?