AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

Analytics
1.9K members online now
1.9K members online now
Learn how to set up goals and Ecommerce tracking, verify accuracy of attribution traffic sources, and discuss funnel visualization, Multi-Channel Funnels, the Goal Flow Report, and Enhanced Ecommerce
 
Guide Me
star_border
Reply

User ID view not showing data

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

 Hello, 

 

We've added the script for the user id data layer on the website and also did the userid configuration in tag manager but still not seeing data in userid view. 

 

What could be wrong?

 

This is the script added on the website:

 

<script>

var ml_uid;

if(userId() != "NLI") ml_uid = userId();

dataLayer['userId'] = ml_uid;

</script> 

 

And here's a screenshot of our GTM setup - http://awesomescreenshot.com/06a5zj7w8a

 

 

1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author tiara m
July 2016

Re: User ID view not showing data

Rising Star
# 2
Rising Star
Hi Tiara,

Have you tested this configuration? Your GTM tag looks Okay but we can't see your variable set up or your dataLayer.

You should be able to see all the data points via this setup: Google Chrome
dataSlayer
https://chrome.google.com/webstore/detail/dataslayer/ikbablmmjldhamhcldjjigniffkkjgpo?hl=en-US

GA Debug
https://chrome.google.com/webstore/detail/google-analytics-debugger/jnkmfdileelhofjcijamephohjechhna...

Look to see that the data is populating as expected.

Hope that helps!

Best,

Theo Bennett

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

View solution in original post

Marked as Best Answer.
Solution
Accepted by topic author tiara m
July 2016

Re: User ID view not showing data

Rising Star
# 2
Rising Star
Hi Tiara,

Have you tested this configuration? Your GTM tag looks Okay but we can't see your variable set up or your dataLayer.

You should be able to see all the data points via this setup: Google Chrome
dataSlayer
https://chrome.google.com/webstore/detail/dataslayer/ikbablmmjldhamhcldjjigniffkkjgpo?hl=en-US

GA Debug
https://chrome.google.com/webstore/detail/google-analytics-debugger/jnkmfdileelhofjcijamephohjechhna...

Look to see that the data is populating as expected.

Hope that helps!

Best,

Theo Bennett

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

User ID view not showing data

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi,

 

I have been testing the user id and all is working as expected. However, i am wondering why certain pages prior to submitting the user id is showing in the user id reporting.

 

I am also noticing certain pages that do no have the user id being parse showing in my reports.

 

Could someone send me some additional details on how it works? and what data is to be expected?

I thought it was collecting data ONLY when the user id is being parsed in the image request.

 

Thanks