Analytics
2.5K members online now
2.5K members online now
Learn how to set up goals and Ecommerce tracking, verify accuracy of attribution traffic sources, and discuss funnel visualization, Multi-Channel Funnels, the Goal Flow Report, and Enhanced Ecommerce
 
Guide Me
star_border
Reply

Product-scope Custom Dimension not reporting

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi all,

I recently set up a Custom Dimension with Product-level scope, however although I can see it being sent in an on-page request it never populates in reports. I have tried sending it as both as part of the Item object and by setting the CD separately. The transactions and items show up fine but with no CD values against them.

I am using UA and Enhanced Ecommerce and if I set the scope to User-level it tracks fine.


Any ideas on what I might be missing?

Thanks
Panos

1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Panos T
February 2016

Re: Product-scope Custom Dimension not reporting

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Alexandra,

I was doing it as a line in the item object, after the name and SKU.
I couldn't see the CD at all even though the rest of the transaction information was reporting OK which was very baffling but then I tried the alternative of adding the sale information in the GTM DL and let GTM pick it up with an Ecommerce tag which worked fine - although the format of the code was more or less the same!

Thanks for your suggestion though!

View solution in original post

Re: Product-scope Custom Dimension not reporting

Visitor ✭ ✭ ✭
# 2
Visitor ✭ ✭ ✭
Hi Panos,

The correct way to send a product-level custom dimension is as part of the item object.
Could you post a screenshot of what you are seeing in the hit sent to Google Analytics? It would help to tell what is happening there.

Thanks,

Alex
Marked as Best Answer.
Solution
Accepted by topic author Panos T
February 2016

Re: Product-scope Custom Dimension not reporting

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Alexandra,

I was doing it as a line in the item object, after the name and SKU.
I couldn't see the CD at all even though the rest of the transaction information was reporting OK which was very baffling but then I tried the alternative of adding the sale information in the GTM DL and let GTM pick it up with an Ecommerce tag which worked fine - although the format of the code was more or less the same!

Thanks for your suggestion though!