Analytics
3.8K members online now
3.8K members online now
Learn how to set up goals and Ecommerce tracking, verify accuracy of attribution traffic sources, and discuss funnel visualization, Multi-Channel Funnels, the Goal Flow Report, and Enhanced Ecommerce
 
Guide Me
star_border
Reply

Enhanced Ecommerce: Conversion data not going to GA dashboard.

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi Everyone,

 

I'm trying to use custom dimensions on a website with GA and I am having an issue where after switching to using Enhanced Ecommerce no transaction data is going through to the website.  I am looking to track product purchases.  On my website I have the following code in the head section:

 

<script type="text/javascript">


  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-1765XXX-X', {
  'cookieExpires':2419200
});

ga('require', 'ec');

ga('send', 'pageview');
</script>

Then further down the page within the BODY I have my eCommerce Data:

<script xmlns="http://www.w3.org/1999/xhtml" type="text/javascript">

	ga('ec:addProduct', {
	'id':'1479472', 
	'sku':'PIPC032516',
	'name':'Pippin',
	'category':'Single Tickets',
	'price':'45.00',
	'quantity':'1.00',
	'dimension1':'BROADWAY',
	'dimension2':'68'
	'dimension3':'7886'
	});

	ga('ec:setAction', 'purchase', {
	'id':'1479472',
	'affiliation':'MOS: 6',
	'revenue':'51.93',
'tax':'.00',
	'shipping':'6.93',
	'currency':'USD'
	});

	ga('send', 'pageview');

</script>

I also have eCommerce and Enhanced eCommerce enabled inside of the Google Analytics dashboard.  However, if I go to Conversions > Ecommerce > Overview I do not see any data coming in.

I have also created custom dimensions in the GA dashboard for the values I am trying to pass in.

 

Are there any "gotchas" or other steps that I need to look out for or might be missing that would explain data not coming through?  I have tried waiting a day to see if data would come through and nothing.  The GA code is tracking real-time users on the site, so I believe the code is installed correctly.


Thanks!