Analytics
4K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

there is unnecessary "www" on front of each URL

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

On a page report before all URLs I have "www" which is not correct. I don't have any filters and I don't understand where they are coming from.

Please help to fix that. 

 

 ScreenClip.png

 

Thanks

1 Expert replyverified_user

Re: there is unnecessary "www" on front of each URL

Top Contributor
# 2
Top Contributor

Hi :-)

In the Property and View settings pages, is the website url entered correctly into each?

Also on the View Settings page, is there a Default Page entered? (not all sites need one entered -
sites built with WordPress for instance)

art01.jpg

 

are you able to provide a link to the website?

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

there is unnecessary "www" on front of each URL

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi,

 

Thanks for the answer.

It's blank and always was blank. In this case, it's Magento, not WordPress.    

 

The website link is truconnect.com

when clicking on a link / (root website) from Google analytics it's adding www link this http://www.truconnect.comwww/ 

there is unnecessary "www" on front of each URL

[ Edited ]
Top Contributor
# 4
Top Contributor

Hi @TruConnect A :-)

Sorry if this seems a bit like 20 questions.

How long have you had google analytics installed, and have the Request URIs in GA reporting always been

incorrect?

Do you have more than one View created in GA?
If so, does the Request URI issue happen in every View?

 

eta..in the Property Settings page and each View Settings page

is the website URL entered correctly to include the www.

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

there is unnecessary "www" on front of each URL

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Hi Bronwyn,

 

1. I started looking to it just a couple of months ago and I'm not sure how long that issue is there. Previous responsible with not the company anymore. 

2. I have 4 different views and only one has that issue. 

3. Yes, all the configurations are correct and include the www. 

 

seems I have to remove that view and create a new one. 

 

thanks for your help. 

there is unnecessary "www" on front of each URL

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

Check view-level filters

there is unnecessary "www" on front of each URL

Top Contributor
# 7
Top Contributor

Hi :-)
I find this strange..


2. I have 4 different views and only one has that issue. 

 

Ok.. so, what is configured differently to this View than the others?
If you compare the View configuration against one that doesnt have the issue, then you should
be able to reverse engineer what is causing the problem within that View.

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

there is unnecessary "www" on front of each URL

Top Contributor
# 8
Top Contributor

@Bartosz D

I agree, re the filters,

however @TruConnect A stated in first post that no filters are applied.

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

there is unnecessary "www" on front of each URL

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

Double check them please, as all GA network calls seem to be fine. Therefore filters are the most likely option