Analytics
7K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

product performance custom report view

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

 

 

Hi Team,

 

We are using enhance e-commerce set up using Google TagManager. We facing some problem in Product list performance report.

Though we passing correct positions to GA, the report shows all products occured in all positions.

 

Eg., Product A alone available there in Zero-th position. But report showing all products available in the same page have impression in Zero-th position.

 

Please provide your comment on this.

ProductListPosition.jpgProductList position

 

DatalayerProductImpression.jpgDataLayer

 

1 Expert replyverified_user

product performance custom report view

Rising Star
# 2
Rising Star

Hi Prasanna K,

 

Have you debugged with dataSlayer and GA Debugger?  Look for them in the Chrome Store to make sure that your dataLayer is not malformed.  Also the position needs to be an integer and not a string... etc.

 

Hope that helps.

 

Best,

 

Theo Bennett

 
 
 

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

product performance custom report view

[ Edited ]
Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi Theo Bennett,

 

Thanks for your reply.

 

I verified in both GA debugger & DataLayer, it is loading fine with actual position. Also position sending information as integer.

 

Still there is wrong data in position. All products showing up in all position in GA report. Uploaded datalayer screenshot in the post

 

Regards

Prasanna Kannan