Analytics
1.9K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

iOS 10+ users is showing 0 pageviews/(not set) in GA if the page they are on was not secure.

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Anyone else seeing this behaviour? 

iOS 10+ users is showing 0 pageviews or Landing page set to '(not set)' in GA if the page they are on was not secure.

Secure pages show up as normal. 

 

The trend of traffic with '(not set)' Landing page matches the trend of people with iOS 10+ 

I'm guessing iOS 10 has had some security changes that is hiding or not passing the page url to GA?

Events are coming through normally.ios10.PNG

1 Expert replyverified_user

iOS 10+ users is showing 0 pageviews/(not set) in GA if the page they are on was not secure.

Rising Star
# 2
Rising Star

Have you tried QAing traffic from an iOS 10 source and looking at the data it offers on Real-Time section? This will help you know if the issue is iOS related or your code implimentation. 

 

Also I would be interested in seeing what happens when you break down your data by Browser ... maybe this is a Safari unique issue? 

 

Let me know if this helps! 

- Josh

 

Joshua, Rising Star
Was my response helpful? If yes, please mark it as the ‘Best Answer.’

iOS 10+ users is showing 0 pageviews/(not set) in GA if the page they are on was not secure.

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi Josh,

 

Thanks for the reply. 

 

We've done some quick realtime checks and it looks like the page (content) shows up in realtime but not in the reporting a few hours afterwards. 

 

We are going to do some more testing and check what behaviour we see in the user explorer report.

 

What we have seen in user explorer so far (from real users) is that all the events that happen on a non secure page show up but no page view. 

 

Will keep digging... 

 

iOS 10+ users is showing 0 pageviews/(not set) in GA if the page they are on was not secure.

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Does anyone have an update or solution here? We're experiencing problems with Google Analytics accuracy since ios 10+ was launched.

I tested 8 REAL TIME ios 10.2.1 users and wasn't able to see them on the site in real time, in my historical data i do have sessions listed for 10.2.1 ios users. 

iOS 10+ users is showing 0 pageviews/(not set) in GA if the page they are on was not secure.

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Hi Lizzie-

 

Were you able to come up with a solution to this issue? Trying to troubleshoot something similar right now.

Marked as Best Answer.
Solution
Accepted by topic author Wahid
November

iOS 10+ users is showing 0 pageviews/(not set) in GA if the page they are on was not secure.

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

Apologies for the late reply!

 

At the end the cause of the problem was a custom dimension which had a realy long string value, more than 256 characters i think. Once we removed that the spike went down. 

 

So looks like iOS 10 doesnt like custom dimensions with long string values.

 

Hope that helps.

 

Thanks

Wahid

 

iOS 10+ users is showing 0 pageviews/(not set) in GA if the page they are on was not secure.

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

Thanks for the help!