Analytics
2.3K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

URLs showing up incorrectly in analytics

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hello,

 

I recently created and implemented a GA account for an external recruitment site used by my company. I got a notification that there was a bad default URL. I noticed when trying to follow links in GA to the individual pages on the site that the default URL was being repeated. For example, if my main page is example.com and I'm looking at the analytics for example.com/page1 GA is actually showing it as example.com/example.com/page1

 

Does anyone know what might be causing this or how to solve the problem?

 

Thanks!

1 Expert replyverified_user

URLs showing up incorrectly in analytics

Rising Star
# 2
Rising Star

In the past when I have seen someone report this type of issue it is an error in either the property or view settings, dealing with the URL or the default page.

URLs showing up incorrectly in analytics

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

That was my suspicion as well. I double checked to see that the Default URL (Property Settings) and the Website's URL (View Settings) were both the same, and they are. They are also both set to http, which should be correct for this site. I have the Default Page box left blank in View Settings, not sure if this needs to change? 

 

URLs showing up incorrectly in analytics

Rising Star
# 4
Rising Star

So leaving the default page blank is ok that is optional. The other two settings even though set to the same thing could be the issue in mine they simply say https://xxx.xxx.com/ if yours follows a simalar pattern then we would need to dig deeper perhaps the problem could be in your code. Can you share your URL?

URLs showing up incorrectly in analytics

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Brian, the Default URL and Website's URL are both set exactly to: www.usventure.wd1.myworkdayjobs.com

The drop down menu in front of both is set to https://

 

However the actual home page is this: https://usventure.wd1.myworkdayjobs.com/USVExternal

URLs showing up incorrectly in analytics

Rising Star
# 6
Rising Star

why are you not using usventure.wd1.myworkdayjobs.com as your URL

 

When I hit www.usventure.wd1.myworkdayjobs.com I get a certificate error

and if I do not include your USVExternal as part of your actual URL I get a 406 error (https://usventure.wd1.myworkdayjobs.com )

Your code deployment looks good but your IIS or Apache configuration seems a little suspect

 

In this case I would suspect you need to look at your actual web sites configuration.

URLs showing up incorrectly in analytics

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

I believe the actual URL's were set up by a third party who put the site together for us. The llS or Apache configuration part is a bit over my head, I'm not really sure what that means. Do you have any suggestions as to what I might tell or ask the company that set this site up for us?

 

By the way, thanks for all your help so far! 

 

Marked as Best Answer.
Solution
Accepted by topic author Alexander J
October 2016

URLs showing up incorrectly in analytics

Rising Star
# 8
Rising Star

Well typically when you type in a URL for instance http://www.yahoo.com you do not need to enter a starting page the underlying configuration should have the default page defined so that the URL can resolve, second the two urls for your website should be the same if I type in usventure.wd1.myworkdayjobs.com or I type in www.usventure.wd1.myworkdayjobs.com they should both resolve and neither should give me a certificate error.

 

Your developer or hosting company should fix these things for you it could be that your configuration at the server level is confusing the GA code.

 

I would ask them to use a normal configuration and determine what is your actual URL does it need the www and does it need the USVExternal and if so why. Typically the only reason one would need either is that you are only renting a sub-domain instead of owning the actual domain.

URLs showing up incorrectly in analytics

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

Alright, I'll go ahead and get in contact with them. Thanks again for your help Brian!