Analytics
2.3K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

This report is unavailable (400)

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

For the past few weeks I have been unable to view Google Analytics on my website due to a 'This report is unavailable (400)' showing up.

 

I have updated both Google Analytics and Google Analytics Dashboard for WP but am still unable to view any data. In fact I have updated every plugin I have installed just in case one of them is causing the problem but I am still unable to view any data.

 

When I go to 'Errors & Debug' I am presented with the following text:

 

Last Error: 2016-11-09 15:03:17: exception 'Google_Auth_Exception' with message 'Error refreshing the OAuth2 token, message: '{
  "error" : "invalid_grant" 

... followed by a chunk of text which this forum is for some reason not allowing me to paste because of "invalid HTML" in the message body.

 

I'd be very grateful if anyone could help me with this issue!

 

1 Expert replyverified_user
Marked as Best Answer.
Solution
Accepted by James_Clemens (Top Contributor)
November 2016

This report is unavailable (400)

Top Contributor
# 2
Top Contributor

Hi :-)
When you state: I have updated both Google Analytics and Google Analytics Dashboard for WP
Are you using the plugin to insert the tracking script for you, or are you using some other method to add the GA tracking to your website?

Sounds like you may need to possibly reauthorize the plugin or there is an issue with the plugin.
Have you checked the plugins support to see if others are having similar/same issues.

Have you asked for support from the plugin developer?


Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

This report is unavailable (400)

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi Bronwyn,

 

Thanks for the prompt reply!

 

Sorry for my lack of clarity, I'm using the plugin.

 

You're right, I have just checked the Settings of the plugin and there is an error message saying "Something went wrong, check Errors & Debug or authorise the plugin".

 

However, when I click on "authorise the plugin" I get the same error message. I have tried clearing authorisation and authorising it again but I still get the error message above.

 

I've noticed that now that I have attempted to re-authorise it, under General Settings, next to Select View: it says 'Property not found'.

 

It did not say this before when the plugin was working correctly, is this a common problem?

 

This report is unavailable (400)

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Please ignore my latest reply.

 

You have been very helpful! After what you said I did a bit of exploring as to why the authorisation wasn't working and realised that for some reason my Google Analytics account was no longer working.

 

I created a new analytics account and re-authorised the plugin and it seems to be up and running again.

 

Many thanks!