Analytics
2.1K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Site Search not showing results

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Our site:

 

www.touchwindow.com

 

We are using Google Custom Search and that works fine.

 

Google Analytics is tracking activity.

 

We are not seeing any results in Google Analytics about Site Search usage and I know we are using it all the time and when we talk to customers they are using it too.

 

Having experimented with different things and waiting days/weeks still we are not seeing what folks are entering in the Google Custom Search box.

 

In GA Admin we have things set like this:

 

1.jpg

 

I found in Google Custom Search a setting for Google Analytics and made it look like this so it looks like it has picked up the GA settings:

 

1.jpg

 

 

Still GA still is not showing any visits with search but we use it all the time:

 

1.jpg

 

 

 

Site Search not showing results

Follower ✭ ✭ ☆
# 2
Follower ✭ ✭ ☆

You need to implement your Custom Search within your site. Currently you're sending users off of your site to the Google Custom Search url, which doesn't include your Google Analytics tracking code. 

Site Search not showing results

[ Edited ]
Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Thanks - I did notice that when a search is performed our GA tracking info in not on the page so GA will never see it so at least it makes sense now why it is not working.

 

So I know what's wrong but missed the part about how to fix it, what I need to do or where to learn how to do it right.

 

I'm not too good at this stuff yet so appreciate the help!

 

I'm not sure how to incorporate it so the GA tracking info gets added.

 

I found a tutorial here:

 

https://moz.com/ugc/how-to-put-google-custom-site-search-into-your-current-website-design

 

In there it mentions that you need to create a page with the GA info so that I have done - but still the search goes out to cse.google.com

 

Then the tutorial says there is a section in the Google Custom Search where you "Specify the URL of the page on your site where you want the search results to appear".  I think that is where I need to enter the page I created (which has the GA code in it).

 

Untitled.jpg

 

In Google Custom Search  can't find that section or the box - where I enter the URL of the page where I want the search results to appear.

 

Is the tutorial wrong/out of date?

 

Am I not looking in the right spot?

 

How do I get to that box where I can enter the URL of the page where I want the search results to appear?

Site Search not showing results

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Yes - I see what the problem is but could use some help finding a place/resource that will guide me in fixing the problem. 

 

Do you know of any links/tutorials/examples that will guide me?