Analytics
2.7K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

No pageviews being reported for a number of weeks

Follower ✭ ☆ ☆
# 1
Follower ✭ ☆ ☆

Hi there

 

I have noticed that one of my website reporting for pageviews in my Google Analytics account has dropped to 0 or 1 for the past month. I have checked that the google tracking code is installed correctly. My Google Search Console account is showing data and also my facebook pixels are firing for this website.

What could be going on please?

1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Jodie M
July

No pageviews being reported for a number of weeks

Top Contributor
# 8
Top Contributor

Hi @Jodie M :-)

The code you removed has fixed the code error..which was a missing closing script tag.

It's all ok now and no errors showing. 

 

You should see your traffic data start to return over the next 24hrs -48hrs.

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

View solution in original post

No pageviews being reported for a number of weeks

Top Contributor
# 2
Top Contributor

Hi @Jodie M :-)

Are you able to please provide a link to the website in question?

Also did you check if there are any filters applied to the View in GA?

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

No pageviews being reported for a number of weeks

Follower ✭ ☆ ☆
# 3
Follower ✭ ☆ ☆

Hi Browyn, thanks so much for making contact. Very much appreciated.

https://knitlikegranny.com

I haven't applied any filters, to be honest I don't know how!!

 

Re: No pageviews being reported for a number of weeks

[ Edited ]
Top Contributor
# 4
Top Contributor

Thanks @Jodie M :-)

 

There are two tracking codes present and a code error present.. 
Currently the codes read as follows

<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]
=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new
Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.
parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js
','ga');
ga('create', 'UA-91238725-1', 'auto');
ga('send', 'pageview');<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-91238725-1', 'auto');
ga('send', 'pageview');
</script>


If its edited to just the following it should fix the issue

<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]
=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new
Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.
parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-91238725-1', 'auto');
ga('send', 'pageview');
</script>

 

 

 

 

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

No pageviews being reported for a number of weeks

Follower ✭ ☆ ☆
# 5
Follower ✭ ☆ ☆

Hi Bronwyn.

I can see this code

script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-91238725-1', 'auto');
ga('send', 'pageview');

</script>

In the section for Genesis Header Scripts in my website. I can't see it doubled up there. Where would I find the double up please?

Thanks again for all your help. Cheers Jodie

No pageviews being reported for a number of weeks

Follower ✭ ☆ ☆
# 6
Follower ✭ ☆ ☆

You also mentioned an error code. What do I need to do with that please?

 

No pageviews being reported for a number of weeks

Follower ✭ ☆ ☆
# 7
Follower ✭ ☆ ☆

Hi Bronwyn, with help I have found the double up and removed it. It was in Settings- Header and Footers. When you have time could you direct me on what to do with the error code you mentioned please. Kind regards Jodie

Marked as Best Answer.
Solution
Accepted by topic author Jodie M
July

No pageviews being reported for a number of weeks

Top Contributor
# 8
Top Contributor

Hi @Jodie M :-)

The code you removed has fixed the code error..which was a missing closing script tag.

It's all ok now and no errors showing. 

 

You should see your traffic data start to return over the next 24hrs -48hrs.

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

No pageviews being reported for a number of weeks

Follower ✭ ☆ ☆
# 9
Follower ✭ ☆ ☆

That's great to hear. Thanks again for all your help Bronwyn. I hope to see the traffic data show up as you said. Fingers crossed Smiley Happy

No pageviews being reported for a number of weeks

Top Contributor
# 10
Top Contributor

You're welcome, if in 24-48hrs it continues to be an issue, pls post back

 

Thanks

Bronwyn :-)

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here