Analytics
2.2K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Mobile Device Info dimension shows as "(not set)"

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Our team would like to analyze metrics for users running our app on a specific Android device. However, we notice that our Analytics data shows a large number of devices as "(not set)" for the "Mobile Device Info" dimension — often more than 50% of total sessions for a given time period.

 

How is the value of the "Mobile Device Info" dimension determined for a particular session? Is it related to the Build.MANUFACTURER and Build.MODEL constants in the Android API? Is there any way we can modify our app to improve the reporting of Mobile Device Info in our Analytics reports and see fewer "(not set)" entries?

 

Thanks!

1 Expert replyverified_user

Re: Mobile Device Info dimension shows as "(not set)"

Rising Star
# 2
Rising Star
Hi Matt,

That seems high. App views to which I have access have less than 2% as not set. It could be that your app has more due to the nature of it but probably not likely.

I think the lookup is done on a database. If you have a way of harvesting the data from the device you could always set this as a custom dimension to compare to what GA is passing.

https://developers.google.com/analytics/devguides/collection/android/v4/customdimsmets

One other thing... are you also sending web traffic to this same property? (in addition to app) that could account for the not set.

Hope that helps.

Best,

Theo Bennett
Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

Re: Mobile Device Info dimension shows as "(not set)"

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Theo,

We're not sending web traffic to this same property, it's only linked to our app. However, our app tends to run on some pretty obscure Android devices. If the "Mobile Device Info" dimension lookup is done on a database, then perhaps the devices are too obscure (or too new) to be included.

We're looking into using custom dimensions right now. Thanks for your help.

Regards,
Matt

Re: Mobile Device Info dimension shows as "(not set)"

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭
Hi Matt,

Did setting the custom dimension help? We're seeing some strange behavior also from Mobile Device Info "(not set)" devices starting on April 4, 2016.

Does anyone know if Google changed anything around that date with regard to device reporting?