Analytics
2.3K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Misssing Data in Reports

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Google Analytics Real Time Report is showing active sessions and page views.  However, if we go into Audience, Behavior, Acquisition, or Conversions reports, the data is only showing for three pages that are not frequently accessed.  I have no javascript errors displaying in console for my page.  To the best of our knowledge, nothing has changed in our implementation or settings.  The three pages that are appearing have slightly different JS code then the others.  Since we didn't change anything, I prefer to no update all the other pages to this JS code.  We have a second site that is working normally. We are in the middle of some performance tuning and need the page speed data.  Plus, the other analytics are needed for additional reporting.  Any thoughts?

 

 

Misssing Data in Reports

Visitor ✭ ✭ ✭
# 2
Visitor ✭ ✭ ✭

Using dev tools in Chromes, I do show that the site is posting data back to www.google-analytics.com/r/collect. 

Misssing Data in Reports

[ Edited ]
Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

We have just over 300,000 sessions for the month so it shouldn't be triggering the delayed data load as that is a per day limit according to documentation.

 

https://support.google.com/analytics/answer/1070983#DataProcessingLatency

Re: Misssing Data in Reports

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Matt, I found your post while preparing to post my own report - we lost data from 11pm - midnight (really 2 full hours) last night, then it restarted again. We have yet to recover the missing data. We also see realtime data flowing correctly, no errors in console, no changes to our code, GA, or GTM at the time of the missing data.

 

Has your data reappeared since your initial post?

 

I've also noticed that if I run the same report (ecommerce overview, past 2 days, hourly report, revenue) in multiple browser windows, I'm getting different results.

Misssing Data in Reports

[ Edited ]
Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

I just connected from home and checked it.  The data from today is now showing up.  We are also still missing data from last night, 9-12.  I checked the appstatus page again, and still no indication that there was an issue.

 

 

Update:  The data is not missing.  It was just to low to trigger a sampling for page load time.  There are captures of page views during that time.

Misssing Data in Reports

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

Gotcha. Glad you resolved it.

 

In our case, it's not a sampling issue: we have a GA 360 license, 100% of sessions are present in the report, no cardinality warnings. The data is still missing for 2 hours on May 30th, despite a record of transactions on our own servers. Still also able to run the same report and get different results each time.

 

Our reseller has confirmed that some of their other clients are also witnessing data display problems.

 

Still no word from Google official.

Misssing Data in Reports

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

Closing this out in case anyone stumbles onto the thread - we were able to escalate our case to Google support and get confirmation that it was a reporting error on their end. It was subsequently fixed.