Analytics
4.8K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Full URL showing up rather than page name in reports

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

For some reason, now when I go to Site Content, Site Speed, or similar pages, Analytics refers to my pages not as their simple path names, such as...

 

/content.html

 

...but with the full URL attached, as in...

/www.website.com/content.html

 

...and this creates a problem with the interface as clicking on the button to display the page or run Site Speed results in an attempt to visit www.website.com/www.website.com/content.html


I have checked and there are no filters set up, so that is not the problem. The data reported appears to be accurate; it's just the Analytics interface that is prepending the URL to the page names.


I do have a subdomain using the same UA code, but I'm not sure why that would be the issue.

Full URL showing up rather than page name in reports

Follower ✭ ☆ ☆
# 2
Follower ✭ ☆ ☆

Hi John,

 

Check with your Admin->view-> Default page settings-> that should be empty if you add anything on default view it will add that to your base url if yourwebsitename.com added it will add yourwebsitename.com/yourwebsitename.com/followedby-url

 

check with your admin view setting default page and let me know it helped you  or not.

 

Thanks

Raman

Full URL showing up rather than page name in reports

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

There is nothing listed under Admin >> View Settings >> Default Page -- I checked that first thing. The URL only appears under "Website's URL."

Full URL showing up rather than page name in reports

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Okay, I think I found it: there was an old filter hiding away, and deleting it resolved the problem. What I have to do now is see whether Analytics sends me an alert that I need the filter, since I probably added it in the first place in response to it saying I was getting reports from redundant addresses. 

Full URL showing up rather than page name in reports

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Okay, there is a continuing issue. While the reports for all new visits are showing up with the site's URL lopped off, all of the data before the change continues to show the full URL. So I have a mix of data showing...

sitename.com/content.html

and

 

/content.html

 

Is there a way to force Analytics to merge those records? I thought it was only putting the URL on there as a display element in the reports, but apparently it is permanently attached to the data I was displaying when the filter was on.