Analytics
2.1K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Event Tracking Working in one view but NOT working in another view within the same property

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Has anyone ran into the issue where event tracking, which is setup through Tag Manager, would show in one view but not another view within the same property? 

 

I'm having that issue and have no idea what is causing it. 

 

Thanks! 

1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Rich G
July 2017

Event Tracking Working in one view but NOT working in another view within the same property

Participant ✭ ✭ ☆
# 2
Participant ✭ ✭ ☆

Hi @Rich G,

 

This can be only related to your filters that you have on that view. Please check your View's filter definitions.

 

I hope this helps.

Regards

View solution in original post

Marked as Best Answer.
Solution
Accepted by topic author Rich G
July 2017

Event Tracking Working in one view but NOT working in another view within the same property

Participant ✭ ✭ ☆
# 2
Participant ✭ ✭ ☆

Hi @Rich G,

 

This can be only related to your filters that you have on that view. Please check your View's filter definitions.

 

I hope this helps.

Regards

Event Tracking Working in one view but NOT working in another view within the same property

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Thanks this did the trick.

 

Event Tracking Working in one view but NOT working in another view within the same property

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

can you please tell me what exact filter cause it. i have the same issue but i only have some ip filers and a consolidate hostname one and i dont think they are related to the problem.

Event Tracking Working in one view but NOT working in another view within the same property

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Hi Everyone. 

 

I've stumbled on a very similar bizzare issue with one of my clients. 

 

All Website Data View is working fine. I can see hits and events in Real Time report. Master View and Test View aren't working (real-time or any of the other standard not not showing any data).

 

At first I've assumed the issue is with one of the filter I've set up, so I tested removing them one by one. Nothing worked.

 

I've also tried simply duplicating the All Website Data view.  The original view is working fine, while the copy isn't. 

 

I've opened each view side by side with the All Website Data view, and compared view settings (setting by setting). There is nothing that should be preventing these views from reporting visitor interactions. 

 

I've also checked all property settings... Nothing... 

 

GA is set up via GTM. Tag Assistant is showing that GA Page View tag is firing correctly. 

 

I've done this implementation hundreds of times, and don't usually have issues. Can you guys suggest more things I could check? 

Event Tracking Working in one view but NOT working in another view within the same property

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

OK. So the issue WAS with one of the filters. Specifically, a filter I've set up to Prepend Hostname To Request URI. 

 

 

Event Tracking Working in one view but NOT working in another view within the same property

A T
Participant ✭ ✭ ✭
# 7
A T
Participant ✭ ✭ ✭

If data is visible in once view and not in other view, it has to be some issue with filters set on that view.