Analytics
2.5K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Device Info is not shown

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

We are using http protocol to report for google analytics. However, we are not seeing the device info populated in the reports on Android.

We add User-Agent field into the header of the post message.

 

User-AgentMozilla/5.0 (Linux; Android 7.1.1; Nexus 6P; Mobile) appName/x.x.x.x

It is working fine on iOS but not Android. Any idea of this?

 

Thanks, 

Weiwei

1 Expert replyverified_user

Device Info is not shown

Rising Star
# 2
Rising Star

WeiWei,

 

GA uses a third party database to populate the device and you don't have to do any customization to the GATC or of the collect function to make this work.

 

If you have enough volume and remove any modifications, you should see this start to populate.

 

Best,

 

Theo Bennett

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

Device Info is not shown

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi, Theo:

 

Thanks for your reply. Do you know how many samples (roughly) is needed to be considered as enough?

 

I removed the header and I found in the real time dashboard, my Nexus 6P fell into the desktop category but not mobile(was reported as mobile category when we have the header). And on the other dashboard, the operating system is shown as not set while was shown as Android before(when we included the header in our rest call).

 

Thanks,

Weiwei