Analytics
3.8K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Data not displaying for - organic keywords, In-market segments reports

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

 

I have recently started my website & have connected GA with it to understand the traffic details. There were a few things in GA which were not working so wanted to understand the reasons behind the same. Currently, there isn't a whole lot of traffic visiting the website. Below are the queries-

    1. The Organic keywords report does not show data as expected & I wanted to understand if this is normal or if there are some changes that I need to make to my GA account. Below is a screenshot of that keyword data:Screen Shot 2017-06-01 at 1.32.46 PM.png

       

    2.  The second thing is: the in-market segment report shows a certain number of sessions at the top but does not display any data. Again is this normal or I need to change any settings? A screenshot below for reference:Screen Shot 2017-06-01 at 1.39.36 PM.png

       

       

    3. Lastly in all the reports whenever I add a segment to All users data, the graphs do not appear. Screenshot below for reference:

      Screen Shot 2017-06-01 at 1.44.14 PM.png

       

 Looking forward to understanding the reasons behind the above & possible solutions. Please bear with me since I am learning by exploring.

Thanks

 

1 Expert replyverified_user

Data not displaying for - organic keywords, In-market segments reports

Rising Star
# 2
Rising Star

Hey Swapneel, 

 

#1 You're getting a lot of ghost referral traffic which is diluting your traffic. Follow the following guide to remove most spam traffic from affecting your website: https://www.ohow.co/removing-google-analytics-spam/ 

 

#2 Can you increase the size of your screenshot to show your settings? 

 

#3 Same goes for #3. I need to see a larger screenshot (make sure to blur out any personal identifying information) to understand what's going on here. 

 

- Josh

Joshua, Rising Star
Was my response helpful? If yes, please mark it as the ‘Best Answer.’

Data not displaying for - organic keywords, In-market segments reports

[ Edited ]
Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi Josh,

 

Thanks so much for the information regarding spam traffic and the related link. With respect to the other points can you elaborate on which settings would you want to see in order to suggest solutions for the other issues.

 

Update: I applied all the filters as mentioned in the website shared by you and it helped a lot in clearing the spam. But my other concern still remains. To further elaborate on those I am including more screenshots:

Upon adding another segment to a report the data disappears including the graphs-Screen Shot 2017-06-01 at 5.54.49 PM.pngData visible with the default All users segment

 

Screen Shot 2017-06-01 at 5.56.50 PM.pngData not visible with the All users - clean segment

So although the All users - Clean segment has 84.29% sessions, there no data displayed below.

 

Thanks

Swapneel

Data not displaying for - organic keywords, In-market segments reports

Rising Star
# 4
Rising Star

Hey Swapneel, 

 

Happy to hear you've applied the filters and domain inclusions/exclusions! 

 

Regarding your data it looks like you haven't passed a threshold in data and you'll need to expand the period of time you're looking at to hopefully get enough data so Analytics will offer you data on your demographics. Basically thresholds are applied when Google Analytics feels there's not enough data to safely anonymize the visitors and keep their privacy. 

 

For more info on thresholds you can check out the following link! : https://support.google.com/analytics/answer/2799357?hl=en#thresholds

 

Let me know if this answers all your questions! 

- Josh

Joshua, Rising Star
Was my response helpful? If yes, please mark it as the ‘Best Answer.’

Data not displaying for - organic keywords, In-market segments reports

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Hey Josh,

 

Thanks for the reply. I get what you said regarding the threshold. Then am I correct in assuming that when the All users report (without the ghost filters) shows me the demographics graph for age & gender that is because the data regarding my website has crossed the required threshold? 

The graphs disappear when I add another segment to the default All users report. I hope this makes sense as I would appreciate any advice cause this is really starting to irritate me :-)

Thanks

Swapneel