Analytics
2K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Custom Variable is captured but no results shown

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hello,

 

When I am debugging my rule to capture custom variable it shows under the Tag Assistant that is it recorded, however under GA profiles (Audience>Custom>Custom Variables) I don't see any values. 

User's Flow:

1. http://allthingsnav.navigation.com/

2. Select an Update for Any Brand and land on a store page where Custom Variable is set

 

I configured custom variable under the Admin Console, but don't see any values populated under Reporting.

 

Thanks,

Darya

1 Expert replyverified_user

Custom Variable is captured but no results shown

Top Contributor
# 2
Top Contributor

Hi Darya,

 

I checked the websites and I don't see in your code where are you setting the values for the custom variable.

You are still using the outdated ga.js implementation, it is strongly recommended to upgrade to Universal Analytics.

 

Please check the document below about migrating from ga.js to analytics.js:

https://www.en.advertisercommunity.com/t5/Google-Analytics-Code/Cross-Domain-Tracking/m-p/870088#M59...

 

Once you updated your analytics implementation you can read about setting custom dimensions and metrics in this document:

https://developers.google.com/analytics/devguides/collection/analyticsjs/custom-dims-mets

 

Let me know if you have questions.


Arnold Majlath, Google Analytics Top Contributor
Circle Me On Google+ | Visit me @ Redfly Digital

Custom Variable is captured but no results shown

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi Arnold,

 

I configured it through Tealium and when I debug it via Google Tag Assistant it is working, but not under GA reporting