Analytics
2.5K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Custom Dimensions showing up for events but not pageviews

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I'm adding a User scope custom dimension that is not showing up on pageviews, but it does seem to be showing up on events.

 

When I look at the total pageviews for a given timeframe, then select a custom dimension as the secondary dimension, I see about 10% of the pageviews that I did before.  I understand that this can happen when the dimension is not set.  However, when I do the same thing for events over the same time period, there is no drop in total events when I select the same custom dimension, which suggests that the dimension is actually set.  According the the bar in the top right, none of these are sampled.

 

Any idea what might be happening or what my next step should be to debug this?

Custom Dimensions showing up for events but not pageviews

Explorer ✭ ✭ ✭
# 2
Explorer ✭ ✭ ✭

Hi, @Jana H

 

If you're sending your events after your custom dimension is set then you'll have no drops in events numbers. 

Consider revising your custom dimension set up and if pageview can be set before cust dim is set.

You can gain insights by looking at user segment with condition "yout custom dimension does not match regex .+"

Custom Dimensions showing up for events but not pageviews

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi,

 

I don't see how the timing of setting the dimension could be the cause.  The documentation clearly indicates that User scoped custom dimensions are applied to all hits in a session, including those sent before the custom dimension was set.  So even if one or two of the pageviews are sent before the dimension is set, it should still be applied to those pageviews in processing.

 

I tried the segment you suggested.  That segment contains more than 95% of users (meaning, as far as I can tell, this isn't set for 95% of users).  I'm still not clear on how it's possible for a User scoped dimension to be attached to an event but not to the user or the session.