Analytics
6.9K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Custom Dimensions not showing up for events

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I've setup several custom dimensions for my property, and I'm sending them with each event captured by GTM (inline with this guide). Using GTM's preview bar I've verified that custom dimensions do indeed get sent. However, when, for example, I go to Google Analytics > Behavior > Events > Top Events and select one of my dimensions as a secondary dimension, all rows simply disappear (I just get There is no data for this view., even though Total Events shows a non-zero number). What am I doing wrong?

1 Expert replyverified_user
Marked as Best Answer.
Solution
Accepted by topic author Olegs J
April

Custom Dimensions not showing up for events

Top Contributor
# 2
Top Contributor

Hi :-)
How long ago did you set them up and start sending them, i have found it can sometimes take up to 48hrs for custom dimension data to populate the standard reports.. 
Also bare in mind, data for the current day that has completed processing into the reports wont be displayed unless the date range at the upper right is adjusted to include the current days date

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Custom Dimensions not showing up for events

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi, thanks for the reply! Indeed, everything is working fine now. Wish Google would somehow warn about the processing delay on this one, instead of just silently failing to find it.