Analytics
2.5K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Content Experiment not showing any sessions

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I have an experiment I have been running for a week, and I have no sessions being reported for either my control or my variation. The experiment is running and directing me to the original and the variation, and my google analytics tag is correctly installed, though not validating because I am using GTM. 

 

My question is: how can I tell if this is just a glitch because of the low traffic around the holidays, or if I am genuinely having a problem?  I can't see anything about my experiment in the debugger object, but I am not sure if that is normal. 

Re: Content Experiment not showing any sessions

Participant ✭ ✭ ☆
# 2
Participant ✭ ✭ ☆
How did you install experiment code on website because as far as I know content experiments in Analytics are not supported with GTM.

Re: Content Experiment not showing any sessions

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
I'm the administrator, so I installed the experiment code right below the opening head tag as instructed. The GTM code is below the opening body tag.

Re: Content Experiment not showing any sessions

[ Edited ]
Participant ✭ ✭ ☆
# 4
Participant ✭ ✭ ☆
I think if you want to use content experiments in GA you have to place GA tracking code directly on page, not via GTM. But i'm not 100% sure.

Re: Content Experiment not showing any sessions

Participant ✭ ✭ ☆
# 5
Participant ✭ ✭ ☆
I have made some tests and even with GA installed via GTM after a few hours there are new sessions in my experiment.
So it seems that this should work together.
Did you check javascript console for errors? Could you provide your website URL?

Re: Content Experiment not showing any sessions

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭
Actually it ended up being a problem between experiments and my analytics setup. Found the solution here: http://stackoverflow.com/questions/11537051/why-arent-results-from-google-analytics-content-experime... I have my domain set, and allow linker set to off. Thank you for your help Tomasz!