Analytics
2.4K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Confusing User Results

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hey there!! 

 

I have discovered a slight discrepancy in my data and I was wondering if you guys could help me out. As you can see GA is showing two users, however only one session. Also, when I go a bit deeper and look at the client ID, GA is only giving me back one user. I am asking myself where the other user has gone? 

 

Bildschirmfoto 2017-03-09 um 12.10.49.pngBildschirmfoto 2017-03-09 um 12.39.38.png

 

Within a different Timeframe which is set for a longer Time, it looks like this:

 

Bildschirmfoto 2017-03-09 um 12.44.10.png

 

Bildschirmfoto 2017-03-09 um 12.47.25.png

 

GA is giving me 3 Users, 4 hits (See graph beneath) but only 2 Unique Client ID's

 

Thank you guys for any help in advance Smiley Happy

1 Expert replyverified_user

Confusing User Results

Rising Star
# 2
Rising Star

Hi Kevin,

 

Is this all valid traffic?  That is do you have any spam that has found it's way in?   It could be a hit from the measurement protocol that is polluting our reports.  e.g. a non interaction hit .  It's hard to say without digging in further.

 

Best,

 

Theo Bennett

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

Confusing User Results

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hello Theo,

 

Well, its hard to say since GA is only giving me data on one User. The other one's completely disappeared every where else but on the home dashboard as well as on the custom report. What do you recommend me doing as trouble shooting? Do you need more Infos or screenshots? 

 

Also, very very strange, when I connect to Power Bi, the numbers do not match either? 

 

Confusing User Results

Rising Star
# 4
Rising Star

Hi Kevin,

 

Well one user is not much to go on... you can look at source/medium and try a secondary dimension of hostname... There is a whole section in this forum that deals with referral spam.  Or wait until you collect more data and see if anything odd persists. 

 

-Theo  

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

Confusing User Results

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Thank you. I have filtered out all Spam before I set up the Account. Also, I do have much more data at hand. Unfortunately the problem persists. Thank you anyway for your help Smiley Happy

Confusing User Results

Rising Star
# 6
Rising Star

Kevin,

 

Are you firing events on page load or using the measurement protocol?  You may have a "user" that does not meet the criteria of new or returning because a rogue event fired and sessions ended before anything else could happen; etc.   I would use tag assistant - look for it in the Chrome store to check and record your site coding if the situation persists and prevents you from using your data.

 

Best,

 

Theo Bennett

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn