Analytics
5.2K members online now
Understand information in your reports and troubleshoot reporting issues such as self-referrals, (not set) data, and inaccurate information
 
Guide Me
star_border
Reply

Campaigns not showing up in my reporting

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

My campaigns (NOT Adwords) are not showing up in my analytics account. I created a campaign in the URL builder and have clicked on the link several times. I've also created multiple campaigns in Benchmark and Mailchimp (which I know have received a good number of clicks), but none of them are showing up in my analytics account. (I'm looking in Acquisition>Campaigns>All Campaigns).

 

The overall traffic for the website is showing up, just not the campaigns. This is for campaigns that are several days old, so I think there should have been time for the campaigns to appear by now.

 

Any advice?

 

Thanks,

Paul

Re: Campaigns not showing up in my reporting

Follower ✭ ✭ ☆
# 2
Follower ✭ ✭ ☆
Hi Paul -

What you could do is to create a test URL and click on it to see if it shows up in the real time report and then to see if it shows up in your reports within 48 hours (usually not that long). Give Medium & Source the same values of those that you are concerned about, but give the campaign parameter a value of 'test', then evaluate it within 24 hours. Heck, you can give all the parameters the same test value to see if that comes through in the real time report.

If it doesn't show up, you should look at whether there might be filter prohibiting this data to show up in your reports. Might overriding the value or even excluding it completely.

Cheers,
Tiaan

Re: Campaigns not showing up in my reporting

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Well that's odd--now the campaigns are showing up. I guess it was just really really slow to update. Maybe there was something I did inadvertently to jump start the process? It almost seems like too much of a coincidence--this is a campaign that started on Wednesday, I check my analytics account Monday and see nothing, then I check my analytics account a couple hours later and the campaigns are showing up.

Re: Campaigns not showing up in my reporting

Follower ✭ ✭ ☆
# 4
Follower ✭ ✭ ☆
There is usually a 24 - 48 time period before your data is processed completely. But your time period mentioned seemed a bit too long. Anyway, I'm glad it worked out.

You can always just test whether hits are coming through by looking at the real time report and sending a test hit. Also, look at using the networks tab in your chrome console to evaluate the hit.