Analytics
2.4K members online now
2.4K members online now
Learn to identify referral spam traffic, as well as best practices to reduce referral spam in your Google Analytics account
 
Guide Me
star_border
Reply

View copy is not capturing new data - zero filters

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Have created a few copies of my original view and am yet to apply any filters however none of the copies are capturing new data?

 

If someone could help please,

 

Corinne

1 Expert replyverified_user
Marked as Best Answer.
Solution
Accepted by topic author Corinne M
January 2016

Re: View copy is not capturing new data - zero filters

Top Contributor
# 2
Top Contributor
Hi Corinne :-)

Has it been at least 24hrs since you created the new Views?
If you change the date range at the upper right of the reports, to also include the
current days date, are you seeing any captured data?
Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Re: View copy is not capturing new data - zero filters

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Bronwyn,

Thanks, no it has not been 24 hours. Looks like I panicked prematurely. I'm just on step one of trying to get rid of all the ghost spam and also trying to exclude our own internal traffic.

Can you recommend an easy step by step guide for a novice such as myself?

Thanks

Corinne

Re: View copy is not capturing new data - zero filters

[ Edited ]
Top Contributor
# 4
Top Contributor

To take the headache out of adding and updating filters for spam removal, you may want to try the following free service
(I have no affiliation with them but i do recommend them for ease of use)
https://referrerspamblocker.com/
If they have already used up their api allowance for the day, you may have to check back with them in x amount of time

(it usually states when its due to tick over on screen) so as to use the service to setup and apply the filters.

Thanks
Bronwyn :-)

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Re: View copy is not capturing new data - zero filters

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Is there a reason why my other views are not showing real time data?

Re: View copy is not capturing new data - zero filters

[ Edited ]
Top Contributor
# 6
Top Contributor

Hi Sarah :-)
Welcome to the Google Analytics Community :-)
Usually the best way to post a question is to start your own thread, its likely to get a quicker response.

Top Contributors, Rising Stars, other GA Community users do not have access to your analytics account, so the more details you are able to give about a particular issue, assists others in providing you with help.

When you say other Views - are some seeing real time data and some not seeing real time data?

Usually it comes down to either filters blocking data in the View
or if its been a few days since you have visited the Real Time reports in a particular View, they go into like
a temporary suspended state (so as to conserve resources)
Once you refresh the report a couple of times, or click to a couple of he differnt real time report sections, then
if there is live traffic on the site, it should start to show in the Real Time reports again.

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Re: View copy is not capturing new data - zero filters

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭
Hello, I have the same problem, none of my views, even the one created years ago, show new data (Yesterday and today's sessions) in the home page.
But I can visualize new sessions in the reporting page, even real time.
Could there be a problem at the property/account level since I have the same issue for all of my views?