Analytics
2.9K members online now
2.9K members online now
Ask questions about filter set-up and issues with using filters in Google Analytics reports
 
Guide Me
star_border
Reply

View for Subdomain not working

Follower ✭ ☆ ☆
# 1
Follower ✭ ☆ ☆

Hi, 

 

I'm tracking both a www. and subdomain.  I want to set up a view that only shows data for the subdomain. 

 

First I set up a view and used a filter to include only traffic to the specific hostname, but it hasn't been reporting any data.  (When I create a segment in my unfiltered view for only traffic to the subdomain, there is traffic, so I know the filter should work)

 

Should I instead be using the "Websites URL" setting in the View Settings rather than a filter on hostname?  Or should the view setting website URL still be my main www. site?

 

Any guesses as to why the predefined hostname filter isn't working?

 

 

1 Expert replyverified_user

Re: View for Subdomain not working

[ Edited ]
Visitor ✭ ✭ ✭
# 2
Visitor ✭ ✭ ✭

Using the hostname is the correct choice. Do you select hostname in segments too? and what subdomain you wanna filter?

 

Important Note: Segments and filtered or non-filtered views are different things! When you create a view, data will be collected after you create that view.

Re: View for Subdomain not working

Follower ✭ ☆ ☆
# 3
Follower ✭ ☆ ☆
Yep. The segment setting is pretty much identical to the view hostname filter. Can't seem to figure out why it's not reporting any traffic.

Re: View for Subdomain not working

[ Edited ]
Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

When did you create the view? As I said, views data will be collected from when you create them.

Re: View for Subdomain not working

Follower ✭ ☆ ☆
# 5
Follower ✭ ☆ ☆
Yes, I'm aware, The include only hostname filter view has been set up for days. It should have been collecting and reporting data.

Re: View for Subdomain not working

Follower ✭ ☆ ☆
# 6
Follower ✭ ☆ ☆
The view was created last week.

Re: View for Subdomain not working

Rising Star
# 7
Rising Star
Hi Leah,

As Farid A, mentioned; the hostname filter is the way to go. Can you share your filter pattern / settings here and the community can comment?

It's important to note that filters cascade. That is if you have two conflicting filters in a view, you will see no data. It's akin to first asking for oranges and then saying from these oranges, show me apples. Once the first filter for oranges has been applied; there are no longer any apples to show.

You can verify that the sub-domain is collecting in your other views by looking at the report under Audience>>Technology>>Network and then selecting hostname as the primary dimension or adding hostname as a secondary dimension in other reports, like your content reports.

Best,

Theo
Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

Re: View for Subdomain not working

Follower ✭ ☆ ☆
# 8
Follower ✭ ☆ ☆
I had a hostname filter set up, for about a week. It was showing zero traffic. But in the unfiltered view, if I created an advanced segment for the hostname, there was traffic. I can't seem to figure out why the hostname filter on a view is not working.

Re: View for Subdomain not working

Rising Star
# 9
Rising Star

Hi Leah P,

This of course requires a consistent tracker across the sub domains and could be as simple as reviewing your filter patterns.  If you want to post a screenshot here of the pattern and other filters in the view, I'd be happy to weigh in.


I'll also reiterate here that if you have two conflicting filters you will get 0 results.

Here is an example of a working sub-domain filter:

 

ss incl subdomain filter.png

 

There are numerous other ways to have the regex work like ^sub etc.; but this is a simple example.

 

Hope that helps.

 

 

Best,

 

Theo Bennett

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

Re: View for Subdomain not working

Follower ✭ ☆ ☆
# 10
Follower ✭ ☆ ☆
Thanks. There were no other filters on the view. We were just using the predefined filter for hostname. Should we use custom instead?