Analytics
5.5K members online now
5.5K members online now
Ask questions about filter set-up and issues with using filters in Google Analytics reports
 
Guide Me
star_border
Reply

My Google Analytics stopped working after setting up filters

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

 

I have started filtering spam a couple of days ago. Since then, 0 visitors were recorded. The way I separated links was by the | sign. I am puzzled why my Analytics stopped working, since I believe I that did everything right?

 

Your help is appreciated.

 

Thanks,

 

Richard

1 Expert replyverified_user

Re: My Google Analytics stopped working after setting up filters

Top Contributor
# 2
Top Contributor
Hi Richard,

Please click "Verify this filter" on the filter settings screen to see how your filter changes your data before applying it. It is recommended to set up a test view and apply the filters to it first and apply it only to your main view once you're satisfied with the results.
Hope this helps.

Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

Re: My Google Analytics stopped working after setting up filters

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Where can I see Verify this filter? Don't see it under the Filters/All Filters tab.

Also, I am 100% sure I would be satisfied with the results since they are all spam and it should be working properly, this is why I am confused.

Is a filter format like this proper? website-stealer.nufaq.com|video--production.com|videos-for-your-business.com|cenoval.ru|www5.free-social-buttons.com

Re: My Google Analytics stopped working after setting up filters

Top Contributor
# 4
Top Contributor
Hi Richard,

If you get no data at all it means that the filters are not working properly.
The verify link is on the bottom of the screen when you are editing a filter.
https://i.imgur.com/zwRrKKT.png
If you get no data in the right column it means that the filter filters out all your data.

Please check out the article below, it will help you fighting spam:
http://help.analyticsedge.com/spam-filter/definitive-guide-to-removing-google-analytics-spam/

Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

Re: My Google Analytics stopped working after setting up filters

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Hi Arnold,

I thought I need to use Custom / Campaign, and add the link there?

Re: My Google Analytics stopped working after setting up filters

Top Contributor
# 6
Top Contributor
Hi Richard,

My image was only to illustrate where can you find the verify link.
You need to use exclude filter, campaign source.
The article I linked above has all the details.

Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital