Analytics
1.7K members online now
1.7K members online now
Ask questions about filter set-up and issues with using filters in Google Analytics reports
 
Guide Me
star_border
Reply

IP Filter Problem

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi All,

i have a problem with IP Filter.

I follow this guide https://support.google.com/analytics/answer/1034840?hl=it but even if the Tag Assistant Recordings were positive in real time view still see when I and other colleagues we connect to the site. The filtrate is generally static ip of our router took from https://www.whatismyip.com/it/. Do you have suggestions on settings to be added to improve the filter? Add the subnet?

 

thanks for any response

2 Expert replyverified_user
Marked as Best Answer.
Solution
Accepted by topic author Gabriele M
July 2016

Re: IP Filter Problem

Top Contributor
# 2
Top Contributor
Hi Gabriele,

what is your exact filter expression you're using? Additionally, do you use IP anonymization in your tracking?

Christoph

Re: IP Filter Problem

Rising Star
# 3
Rising Star
The Help Centre guide gives clear instructions, above all the screenshot in Esclusione di un singolo indirizzo IP.

As webfield hinted, are you making use of IP anonymization by any chance? If in doubt, could you post the URL to the site in question? Happy to have a look.

Re: IP Filter Problem

[ Edited ]
Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Hi Christoph,
ty for quickly reply, I tried to disable the IP anonymization from wordpress plugin and now it works. Thanks a lot of suggestions. I must have read it wrong and I thought that filtering works before IP anonymization.

 

ty Rodrigues too for help.

Re: IP Filter Problem

Top Contributor
# 5
Top Contributor
Hi Gabriele,

okay, that's fine!

You may actually use both IP exclusion and IP anonymization if you want to - you only have to be aware that anonymization inserts a '0' for the last IP octet [1] and that this occurs before any view filtering. In this way, IP filter ranges often fall outside because the filter is set too fine and doesn't contain the '0' at last IP octet.

Christoph

[1] https://support.google.com/analytics/answer/2763052?hl=en