Analytics
2.3K members online now
2.3K members online now
Ask questions about filter set-up and issues with using filters in Google Analytics reports
 
Guide Me
star_border
Reply

Filtered view by hostname not updating reports

Follower ✭ ✭ ☆
# 1
Follower ✭ ✭ ☆

I have some filtered views that only include traffic from certain hostnames. These were set up ~18 hours ago. They are all configured exactly the same with just one filter to only include traffic from a specific hostname.

 

Some of these are working well but, for others, the reports are all at zero visits. However, when I go to the Real-Time feature for these views, I can see that it is seeing and filtering the visits correctly.

 

Does anyone know how I can get the reports to update? I have never seen GA so long to take to update, and I'm not sure if this is a bug.

1 Expert replyverified_user

Re: Filtered view by hostname not updating reports

Top Contributor
# 2
Top Contributor

Hi Ralph Andrew C,

How have you configured these filters? Can you include screenshots? More importantly, did you set up individual Include filters for each hostname? From Google's support docs:

 

If you apply multiple Include Filters, the hit must match every applied Include Filter in order to save the hit. To include multiple patterns for a specific field, create a single include filter that contains all of the individual expressions separated by '|'.
Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: Filtered view by hostname not updating reports

Follower ✭ ✭ ☆
# 3
Follower ✭ ✭ ☆

Hi, it looks like it started working about an hour ago, but only for today's data. Yesterday's data was never processed.

 

The strange thing is some filtered views started working from the get-go while others (the majority), only seem to have started processing after 18 hours. Is this normal GA behavior or is it potentially a bug?

 

In any case, it looks like it's processing now, so I'll continue to monitor it.

 

The configuration for this single filter was:

 

  • Filter Type: Predefined
  • Include only > traffic to the hostname > that contain
  • Hostname: domain.com