Analytics
3.1K members online now
3.1K members online now
Ask questions about filter set-up and issues with using filters in Google Analytics reports
 
Guide Me
star_border
Reply

Custom Dimension Missing from Filters

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Typically I go to any one of my views in View --> Filters --> Then choose the filter to edit. 

 

I have been using a custom Include filter with a custom dimension, but that custom dimension is missing from the drop-down menu for all my views, now. The custom dimension is still there in the admin settings, though. In fact, the whole edit screen seems to be buggy for me when I try to adjust the filter. Any ideas?

 

It also has a "Loading..." indicator stuck at the top of the window that never completes.

1 Expert replyverified_user

Re: Custom Dimension Missing from Filters

Top Contributor
# 2
Top Contributor
Hi David W G,

That sounds strange indeed. Have you tried to close the browser and maybe even clear cache and start it all up again?
Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: Custom Dimension Missing from Filters

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Yep. I've cleared the cache, gone into private mode, disabled all extensions, tried across browsers, and attempted across computers, but it still has the same problem. This isn't what I typically see when editing a filter.

Right now every time I edit *any* filter, the usual options under the Custom tab are not there. Instead, it always defaults to the predefined "ISP", regardless of whether you choose the predefined or custom tab. It's driving me nuts! Smiley Happy

I would post a screenshot, but after several attempts, I could not get the editor in this forum to successfully load an image.

Re: Custom Dimension Missing from Filters

Top Contributor
# 4
Top Contributor
Hi David W G,

I think it may be a more widespread problem. My colleague just showed me what looks like what you described, where the filter view is "different". In this case, if it's widespread, then you'll just need to hang tight while it gets ironed out!
Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: Custom Dimension Missing from Filters

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

I hope so! It's only happening in one account, too. The others seem to be fine. 

 

Re: Custom Dimension Missing from Filters

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

Has your coworkers filters cleared up yet? 

Re: Custom Dimension Missing from Filters

Top Contributor
# 7
Top Contributor
Yes, I just checked and it looks like it's back to normal. How about yours?
Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: Custom Dimension Missing from Filters

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭
Unfortunately, no. The filters are still screwed up and it's preventing me from updating or revising them. When I try to add a new filter under the account level, I can't see my dimensions either: But if I try to create a new filter under the View settings, I can finally see my dimensions again, but even if I create the new view and try to edit it... Still screwed up.

Re: Custom Dimension Missing from Filters

Follower ✭ ✭ ✭
# 9
Follower ✭ ✭ ✭
did you manage to resolve it?

You probably trying to create filter at 'Account' level, where-as custom dimensions are 'Property' level objects. Try create / edit filter from 'View' level settings and you'll be able to see all 'Property; level custom dimensions.

Cheers!

/Vibhor