Analytics
1.7K members online now
1.7K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

utm info and URL not working if clicked from 3rd party site, appears as "Referrral" instead

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hello All!

 

 

We are using a custom URL w unique number and standard utm logic:

https://domain.com/redirect?umc=uniquenumberhere&utm_source=relay&utm_medium=sms&utm_campaign=RELAY1...

 

My testing worked out perfectly when I input the URL into an internet browser: 1) I see the complete URL used for back-end reconciliation purposes), AND I see the utm_ related data in reports on Source / Medium / Campaign.

 

My reporting problems arise when the user clicks on the URL from a 3rd party web site:

  1. I do not see the full URL the user clicked on (so I cant see the unique number for back-end reconciliation)
  2. The utm code (ie Source = Relay) is not appearing on standard reports. Instead, it is showing as a "Referral" from the relay company's web site. I am glad at least I can see the traffic and goal completion came from the vendor, but I just don't understand why the utm code works perfectly if I plug it into the browser myself vs not working if clicked from the 3rd party vendor's web site.

I am perplexed as to why my test of inputting right into the browser works perfectly but when from a referring site it does not. Wondering if the referring site's platform is doing something wrong.

 

Thanks all for any input!

 

Jessica

1 Expert replyverified_user

Re: utm info and URL not working if clicked from 3rd party site, appears as "Referrral" in

Top Contributor
# 2
Top Contributor
Hi Jessica,

is there a chance that the 3rd party website is making changes to your URL when redirecting?
VP & Chief Evangelist at Hub'Scan | Contact me
Level 80 Digital Analytics Warrior, KPI Therapist and Keeper of the One True Tagging Plan