Analytics
3K members online now
3K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Universal Analytics discrepancies in Sessions and EE

Follower ✭ ☆ ☆
# 1
Follower ✭ ☆ ☆

Hi,

 

one of our clients is in the middle of an Universal Analytics migration, but there are some discrepancies in the data compared to classic analytics that we cannot easily explain. 

 

1) We see about -6% in sessions leading to a +6% increase in conversion rate, which kinda distorts year-on-year comparison

2) Looking at the Enhanced Ecommerce Shopping Behaviour report, we see that "sessions with transactions" and transactions (E-commerce Overview) report do not correspond. We see a 2-3% discrepancy between the two metrics. We explained this as this 2-3% difference is explained by users that perform multiple transactions in one session, but 3% of users showing this behaviour is quite large.

 

Has someone experienced these kinds of discrepancies in data before? 

 

Thanks in advance!

Universal Analytics discrepancies in Sessions and EE

Follower ✭ ✭ ✭
# 2
Follower ✭ ✭ ✭

Hi,

 

May be analyse user using "User Explorer" who made multiple purchases . This will explain you about the discrepancies.

 

Thanks,

Sura

Universal Analytics discrepancies in Sessions and EE

Follower ✭ ☆ ☆
# 3
Follower ✭ ☆ ☆

Hi Suradha,

 

The 3% discripancy seems unlikely for our client, which sells high-end clothing items. Seems more likely that the discripancy can be explained by some other factor that we are unaware of in this point in time.

 

Best,

Joost

Universal Analytics discrepancies in Sessions and EE

Follower ✭ ✭ ✭
# 4
Follower ✭ ✭ ✭

Hi Joost,

 

Did you check whether the GA/GTM code is present on all pages using screaming frog?

 

I had similar experience with my client in the past, tracking was missing in some new sale pages also on other client there was some JavaScript conflict which was blocking GTM to execute. 

 

Thanks,

Sura