Analytics
3.6K members online now
3.6K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

UTM not tracking - due to GTM code?

Follower ✭ ☆ ☆
# 1
Follower ✭ ☆ ☆

Hi all,

 

I'm aware there are similar posts on this. I'm fairly new to my company and UTM parameters have always worked no problem for me in the past, but this situation is baffling me

 

Have created the below link:

 

https://www.oddschecker.com/it/?utm_source=newsletter&utm_medium=email&utm_campaign=test

 

When I test this link in Real Time on GA, source/medium appears as direct/(none) still?

 

I've tested this on my phone using 4G connection, so my data is not filtered out of the GA view. And I can identify that my session has been picked up

 

GA has been implemented on to the site using GTM. One thing I have noticed is that both bits of GTM code are in the <body> section of the page. Could this cause the issue? The section below should be in the <head> but it is in the <body>

 

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-XXXXXX');</script>
<!-- End Google Tag Manager -->

 

This may well not be the reason, but I'm struggling to identify any other reason why the link wouldn't work?

 

I've waited more than 24 hours for my session data to appear in reports, but it is not there and I imagine just categorised as (direct)/none still

 

Any help?

 

Thanks

 

Cyrus

 

 

1 Expert replyverified_user

UTM not tracking - due to GTM code?

Top Contributor
# 2
Top Contributor

Hi,

 

When you arrive to the site through the tagged link, the query string is stripped so the GA code cannot collect the utm data.

It's most likely server settings, you need to make sure that the query parameters are not removed.

 

Hope this helps.


Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

UTM not tracking - due to GTM code?

Follower ✭ ☆ ☆
# 3
Follower ✭ ☆ ☆

Thanks for the reply

 

Currently no url query parameters have been removed in the GA admin interface. 

 

So there's something within the code removing the UTM parameters?

 

 

UTM not tracking - due to GTM code?

Top Contributor
# 4
Top Contributor

Hi,

 

No, not the code, it's something to do with your server or site setup. If you visit the tagged URL you can see that the parameters are removed. Actually it removes any query parameter: https://www.oddschecker.com/it/?test=123

You need to fix it to allow query parameters in order to make utm tagging work.


Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

UTM not tracking - due to GTM code?

Follower ✭ ☆ ☆
# 5
Follower ✭ ☆ ☆