Analytics
1.9K members online now
1.9K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

UTM Campaigns not showing in Google Analytics dashboard

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

My UTM Campaigns are not showing up in my Google Analytics dashboard. The multiple URLs I have made are getting clicked but there is no data in the dashboard.

 

Here is one of the UTMs:

https://beatpcos.com/?utm_source=SFC%20Menu&utm_content=Beat%20PCOS%20Landing%20Page%20SFC%20Menu

 

This is my site: 

https://beatpcos.com/

 

This is my Google Analytics domain:

UA-65829410-3

 

This is my Acquisitions > Campaigns dashboard:

Screen Shot 2017-01-30 at 8.18.00 AM.png

 

I am using the Tag Assistant and it is receiving and sending all requests just fine.

 

How can I resolve this?

1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by Bronwyn V (Top Contributor)
6d

UTM Campaigns not showing in Google Analytics dashboard

Participant ✭ ✭ ✭
# 2
Participant ✭ ✭ ✭

Hi Kym,

 

Processing latency is 24-48 hours in Google Analytics so it may take up to 48 hours before you can see accurate numbers in your regular reports.

 

One more tip: I recommend using Campaign Source, Campaign Medium and Campaign name parameters as well if you use URL builder. It's way better for you to analyze data later on.

 

Go to your website through this tagged URL that you see below and then check your Real-Time report in Google Analytics. Do you see yourself and those custom campaign parameters there in this Real-Time report?

 

https://beatpcos.com/?utm_source=test-source&utm_campaign=test-campaign&utm_medium=test-medium

 

Campaign Name: test-campaign

Campaign Source: test-source

Campaign Medium: test-medium

 

If you see those parameter there, everything is fine.

 

Hope this helps.

Taavi

 

 

 

View solution in original post

Marked as Best Answer.
Solution
Accepted by Bronwyn V (Top Contributor)
6d

UTM Campaigns not showing in Google Analytics dashboard

Participant ✭ ✭ ✭
# 2
Participant ✭ ✭ ✭

Hi Kym,

 

Processing latency is 24-48 hours in Google Analytics so it may take up to 48 hours before you can see accurate numbers in your regular reports.

 

One more tip: I recommend using Campaign Source, Campaign Medium and Campaign name parameters as well if you use URL builder. It's way better for you to analyze data later on.

 

Go to your website through this tagged URL that you see below and then check your Real-Time report in Google Analytics. Do you see yourself and those custom campaign parameters there in this Real-Time report?

 

https://beatpcos.com/?utm_source=test-source&utm_campaign=test-campaign&utm_medium=test-medium

 

Campaign Name: test-campaign

Campaign Source: test-source

Campaign Medium: test-medium

 

If you see those parameter there, everything is fine.

 

Hope this helps.

Taavi

 

 

 

UTM Campaigns not showing in Google Analytics dashboard

[ Edited ]
Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hello,

 

I went to the UTM and checked Real Time. It is showing 1 active users. I am seeing none of those parameters. 

 

What is going wrong?

UTM Campaigns not showing in Google Analytics dashboard

Participant ✭ ✭ ✭
# 4
Participant ✭ ✭ ✭

Kimberly, click on this link once again and check Real-Time -> Traffic Sources report. Do you those parameters there?

 

It will take 10-20 seconds maximum.

 

Hope this helps.

Taavi

UTM Campaigns not showing in Google Analytics dashboard

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

I do see those parameters yes. I checked my own UTM again:

 

https://beatpcos.com/?utm_source=SFC%20Menu&utm_content=Beat%20PCOS%20Landing%20Page%20SFC%20Menu

 

and I am seeing an additional active user but the Medium = (none), and Source = (direct).

 

I did set the Medium and Source when I created the above UTM so I am unsure what the problem is.

UTM Campaigns not showing in Google Analytics dashboard

A T
Participant ✭ ✭ ✭
# 6
A T
Participant ✭ ✭ ✭

try hitting the url from new incognito mode chrome window.

 

or a different browser. and check in real time.

UTM Campaigns not showing in Google Analytics dashboard

Participant ✭ ✭ ✭
# 7
Participant ✭ ✭ ✭

Kimberly, in your tagged URL, there's no utm_medium. I guess, you forgot it. Smiley Happy

 

Try creating this tagged URL once again and fill out all those fields: Campaign Name, Campaign Source, Campaign Medium using URL builder.

 

Let us know how it goes.

Taavi

UTM Campaigns not showing in Google Analytics dashboard

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭

Hi Taavi!

 

So, three days ago I did as you said and created a UTM code with all three parameters. But nothing is showing in Google Analytics Campaigns. Funnily enough, that test UTM you linked above is showing but that is the only one.

 

https://beatpcos.com/?utm_source=SFC%20Blog%20Posts&utm_medium=Hyperlink&utm_content=Beat%20PCOS%20L...

 

Is there still something wrong with my link above? (Yes, I clicked it a few times in Incognito mode on Chrome).

Re: UTM Campaigns not showing in Google Analytics dashboard

[ Edited ]
Participant ✭ ✭ ✭
# 9
Participant ✭ ✭ ✭

Hi Kym,

 

Take a look at this URL: https://beatpcos.com/?utm_source=SFC%20Blog%20Posts&utm_medium=Hyperlink&utm_content=Beat%20PCOS%20Landing%20Page%20SFC%20Blog%20Posts

 

You haven't used utm_campaign, that's why you don't see anything in the Google Analytics Campaigns report. Smiley Happy

 

If you're generating campaign URL's, I always recommend filling out all those fields that I mentioned above:

 

1) Campaign Source

2) Campaign Medium

3) Campaign Name

 

Here you can see this test URL that I created previously: https://beatpcos.com/?utm_source=test-source&utm_campaign=test-campaign&utm_medium=test-medium

 

So if you're tagging URLs with the Campaign URL builder in the future make sure you fill out all those fields:

 

builder.png

 

Hope this helps. Let us know if you have any further questions. Smiley Happy

 

Cheers,

Taavi

 

Re: UTM Campaigns not showing in Google Analytics dashboard

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭

Oh of course!

 

I have tested again and it has all worked out. Thank you, it is now resolved.

 

Could you please help me out with my other thread? You've been so helpful! Smiley Happy https://www.en.advertisercommunity.com/t5/Google-Analytics-Tracking-Goals/HELP-Inaccurate-Conversion...