Analytics
3.3K members online now
3.3K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Two different GA codes on wordpress site, unable to find extra code to remove it

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

I've just built my first wordpress site and installed GA tracking code. I used the Google Tag Assist Chrome plugin (on a mac in using chrome as browser) and learned that I have 2 different GA tracking codes installed.  When I go into the wordpress admin, I can only find one of the codes.  I am in no way a coder, but I went to my site in chrome and looked at the code, doing a ctrl-f to find the code I wanted to remove.  I could not find it, but the correct code did show up.  Does anyone know how to find the extra code and remove it?  I'm in wordpress 4.6.1

 

Additionally, when I went to the Tag Assist report and tried to click on the extra code, I get a message saying that I don't have permission in GA for its views.  I logged out and back in with every one of my google accounts and none work, so I'm not even able to see that code in GA.  

 

Any advice would be really appreciated.  I'd like to remove the code from my site and also remove that instance of it from Google Analytics.

 

Thanks in advance for anyone with insight or suggestions.  I've spent hours and hours over several days trying to figure this out. 

 

 

2 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Gina B
November 2016

Two different GA codes on wordpress site, unable to find extra code to remove it

Rising Star
# 4
Rising Star

You have the same Google tracking code installed twice.  It appears you are using a Visual Composer powered theme - you have it entered into two different locations.  Could it be possible that you put it in manually in the theme, and also via Customize?

 

The easiest way for a non-programmer to troubleshoot this is to simply temporarily turn off all your plugins.  Did one or both tracking codes go away?  If so, keep enabling plugins one at a time until you see one tracking code appear :-)

 

If you turn off all the plugins and both codes still exist - did you user Appearance > Editor to add in code as well as a form field in your admin?  

 

 

Tag Assistant isn't very smart when it comes to multiple browser logins.  Log completely out of Google, and then log in only using whatever account you use to see your actual Google Analytics account UA-82843100-1.  You should then get access.

 

 

_________________________________________________________________________
Director of Marketing | Nehmedia | Partner Profile

View solution in original post

Two different GA codes on wordpress site, unable to find extra code to remove it

Top Contributor
# 2
Top Contributor

Hi,

 

it seems that the extra tracking code is not belong to your property, it is possible that you are pulling content from another website and it has it's own analytics tracking code. If you can post your site URL, I'd be happy to look into it for you.


Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

Two different GA codes on wordpress site, unable to find extra code to remove it

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi Arnold,

I'd really appreciate that.  The site is www.edgecustomspaces.com

 

I thought of that and made sure I deleted a couple of themes in wordpress that I tried before landing on the current one, but that didn't resolve the issue. 

 

Thanks!

Gina

Marked as Best Answer.
Solution
Accepted by topic author Gina B
November 2016

Two different GA codes on wordpress site, unable to find extra code to remove it

Rising Star
# 4
Rising Star

You have the same Google tracking code installed twice.  It appears you are using a Visual Composer powered theme - you have it entered into two different locations.  Could it be possible that you put it in manually in the theme, and also via Customize?

 

The easiest way for a non-programmer to troubleshoot this is to simply temporarily turn off all your plugins.  Did one or both tracking codes go away?  If so, keep enabling plugins one at a time until you see one tracking code appear :-)

 

If you turn off all the plugins and both codes still exist - did you user Appearance > Editor to add in code as well as a form field in your admin?  

 

 

Tag Assistant isn't very smart when it comes to multiple browser logins.  Log completely out of Google, and then log in only using whatever account you use to see your actual Google Analytics account UA-82843100-1.  You should then get access.

 

 

_________________________________________________________________________
Director of Marketing | Nehmedia | Partner Profile

Two different GA codes on wordpress site, unable to find extra code to remove it

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Hi Phillip,

you are correct, I did have the 100-1 code installed both in the visual composer within the theme and also from a GA plug in.  I also seem to have another ghost code (774-3) installed as well and that has been what I've been trying to get rid of.  

 

I was able to go into the visual composer and remove one of the 100-1 instances.  My problem is that the tag manager is still showing that I have the other code (774-3) installed.  I removed the 100-1 from the visual composer, it is still entered in the GA plug in, and re-ran the tag assist. Now the reports no instances of 100-1 (though I have it entered in the plug in) but I'm able to see the report for 774-3 - I wasn't before, and took the advice to log out of all google accounts and log back in.  

 

So, I decided to go back and remove the code from the plugin and then disable the GA plug in.  I went into the theme ->settings->general settings ->CSS script related and pasted back in the full tracking script for 100-1. The result is the same thing I experienced before - 2 tracking codes.  I'm not able to view the results for 774-3, but the report for 100-3 shows everything for that code to be fine.

 

So strange.  Any thoughts?

 

I really appreciate your advice.

 

Gina

Two different GA codes on wordpress site, unable to find extra code to remove it

Rising Star
# 6
Rising Star

I only see 100-1 using Tag Assistant and confirmed with Ghostery.  Try logging completely out of Wordpress and revisiting your site.  Some plugins and template developers stick GA code into their admin panels to track where there users are.

_________________________________________________________________________
Director of Marketing | Nehmedia | Partner Profile

Two different GA codes on wordpress site, unable to find extra code to remove it

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

Phillip,

I can't thank you enough.  I just did as you suggested and now, for the first time, am seeing only one code 100-1.  Your advice has been extremely helpful.