AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

Analytics
2.5K members online now
2.5K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Second tracker not working in site using Linker

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

The current setup is 3 related sites each with a separate GA account. I want to put all 3 into one account as different properties.

 

In 2 of them I've used:

  ga('create', 'UA-XXXXXXXX-X', 'auto');
  ga('create', 'UA-XXXXXXXX-X', 'auto', 'combinedTracker'); // new
  ga('send', 'pageview');
  ga('combinedTracker.send', 'pageview'); // new

That works ok.

 

On the third, which uses Linker (and ecommerce) I have:

    ga('create', 'UA-XXXXXXXX-X', 'auto', {'allowLinker': true});
    ga('create', 'UA-XXXXXXXX-X', 'auto', 'combinedTracker' {'allowLinker': true}); // new
    ga('require', 'linker');
    ga('require', 'ec');
    ga('linker:autoLink', googleDomainList);
    ga('send', 'pageview');
    ga('combinedTracker.send', 'pageview'); // new

but no tracking is coming through to the combined account.

 

Where am I going wrong?

1 Expert replyverified_user

Re: Second tracker not working in site using Linker

Top Contributor
# 2
Top Contributor

Hi,

 

You have a syntax error, missing comma in the second create command:

    ga('create', 'UA-XXXXXXXX-X', 'auto', {'allowLinker': true});
    ga('create', 'UA-XXXXXXXX-X', 'auto', 'combinedTracker', {'allowLinker': true}); // new
    ga('require', 'linker');
    ga('require', 'ec');
    ga('linker:autoLink', googleDomainList);
    ga('send', 'pageview');
    ga('combinedTracker.send', 'pageview'); // new

 Hope this helps.


Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

Second tracker not working in site using Linker

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Aargh! Thanks Arnold!