Analytics
2.1K members online now
2.1K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Not seeing results from separate analytics on subsection

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

 

First of all, I'm using Wordpress. I have a new section consisting of a few pages, and want to check the performance of it. Not sure if there is any different between subdomain and subdirectory, but the section is located like so: www.example.com/somewhere/else/newsectionhere

 

I already have UA-XXXXXXXX-1 installed in "header.php", this will make it appear on all public page. This works so far.

 

I then installed UA-XXXXXXXX-2 onto the PHP template of that section, this will make only pages of that section having two analytics, because UA-XXXXXXXX-1 is installed through "header.php", it appears above UA-XXXXXXXX-2. After a few days with UA-XXXXXXXX-2 installed, I'm not seeing any results.

 

Does it matter that a page has two analytics tracking codes?

1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Kevin L
December 2015

Re: Not seeing results from separate analytics on subsection

Top Contributor
# 2
Top Contributor
Hi Kevin L :-)
In the php template of the new section where the tracking code for UA-XXXXXXXX-2 has been placed,
try making the following changes to the tracking code by naming the tracker clientTracker.

ga('create', 'UA-XXXXX-2', 'auto', 'clientTracker');
ga('clientTracker.send', 'pageview');

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

View solution in original post

Marked as Best Answer.
Solution
Accepted by topic author Kevin L
December 2015

Re: Not seeing results from separate analytics on subsection

Top Contributor
# 2
Top Contributor
Hi Kevin L :-)
In the php template of the new section where the tracking code for UA-XXXXXXXX-2 has been placed,
try making the following changes to the tracking code by naming the tracker clientTracker.

ga('create', 'UA-XXXXX-2', 'auto', 'clientTracker');
ga('clientTracker.send', 'pageview');

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Re: Not seeing results from separate analytics on subsection

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Thanks, it's working now.

Re: Not seeing results from separate analytics on subsection

Top Contributor
# 4
Top Contributor
You're welcome :-)
Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here