Analytics
4.2K members online now
4.2K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Internal promotions showing double in the enhanced ecommerce report

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I have below GA code in my test page:

 

 

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics_debug.js','ga');

  ga('create', 'UA-XXXXXXXX-XX', 'auto');
  
  ga('require', 'ec');
ga('send', 'pageview');

ga('ec:addPromo', {
'name': 'Blog Post #300'
});

ga('ec:addPromo', {
'name': 'Blog Post #301'
});
ga('send', 'event', 'Internal Promotions', 'impressions',{
'nonInteraction': 1
});

</script>

 

 

Now for every page load, this fires one call or beacon or ajax request to GA ( I checked with firebug net tab). Below is the call being sent to GA per page load:

 

_s2
_uSCCAAEIJI~
_vj41d
a328634056
cid141732542.14503435057
dewindows-1252
dlhttp://yhst-72832473607340050082876.edit.store.example.net/RT/NEWEDIT.yhst-72832473607340050082876/0280e489f014/C1JxpAAB
dtexample-test.info
eaimpressions
ecInternal Promotions
fl20.0 r0
je1
jid 
ni1
promo1nmBlog Post #300
promo2nmBlog Post #301
sd24-bit
sr2048x1152
tevent
tidUA-XXXXXXXX-XX
ulen-us
v1
vp2048x622
z1607933226

 

But in the GA reports, I always see 2 impressions both for Blog Post #300 and Blog Post #301.

 

Is this some bug on the GA side?

 

Any help would be great appreciated.

 

Thanks,

Chirag

Re: Internal promotions showing double in the enhanced ecommerce report

Explorer ✭ ✭ ✭
# 2
Explorer ✭ ✭ ✭

Re: Internal promotions showing double in the enhanced ecommerce report

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
I have actually waited for more than 48 hours. I had fired this code once on last Friday evening and checked instantly and it was showing 2 impressions each for Blog Post #300 and Blog Post #301. It is still showing the same whereas it has been more than 48 hours. I am totally convinced that this is some bug on GA side. You can also try firing this code on any page and test it out. Thanks.