Analytics
2.2K members online now
2.2K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

I'm getting a "Missing HTTP Response" on my site's login page; any idea why?

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi all, 

 

I've been receiving "Missing Tracking Code" notifications on my GA dashboard for a while. Concerned, I checked out my site with Google's Tag Assistant and it registered a "Missing HTTP Response" error on my site's login page, which is just a login form.

 

Google's support page (https://support.google.com/tagassistant/answer/3059154#http_response) says that this error means "that the Google Analytics code is not implemented properly on the page and no data will be collected."

 

However, my account is tracking properly past the login. As in, once I log in to my site, all events and hits are coming in normally, as far as i can tell, and Google Tag Assistant says my tracking code is installed properly, though it suggests this optimization: "Tag is included in an external file" ( https://support.google.com/tagassistant/answer/3059154?ref_topic=2947092#external_file ).

 

Why is this error occurring on my site's login page? 

And is it at all concerning? Or can I safely ignore, given that the rest of my site is tracking properly?

 

Thanks!

Zack 

1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Zack M
June 2016

Re: I'm getting a "Missing HTTP Response" on my site's login page; any idea why?

Follower ✭ ✭ ☆
# 2
Follower ✭ ✭ ☆
Hey Zack,

If the tracking snippet is not installed on the page you want tracking that error will occur. It sounds like it is installed on all pages except your login page. Also make sure the snippet is installed on the page itself rather than in an external file such as a .js or other. If you are able to get the correct hits then that issue probably isn't a huge issue. You do although run the risk of losing tracking if that external file doesn't load for some reason.

Hopefully this helps,
Omar

View solution in original post

Marked as Best Answer.
Solution
Accepted by topic author Zack M
June 2016

Re: I'm getting a "Missing HTTP Response" on my site's login page; any idea why?

Follower ✭ ✭ ☆
# 2
Follower ✭ ✭ ☆
Hey Zack,

If the tracking snippet is not installed on the page you want tracking that error will occur. It sounds like it is installed on all pages except your login page. Also make sure the snippet is installed on the page itself rather than in an external file such as a .js or other. If you are able to get the correct hits then that issue probably isn't a huge issue. You do although run the risk of losing tracking if that external file doesn't load for some reason.

Hopefully this helps,
Omar

Re: I'm getting a "Missing HTTP Response" on my site's login page; any idea why?

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hey Omar,

Sorry for my super-delayed response, but thanks for answering and clarifying. Super helpful. Load off my mind Smiley Happy

Thanks!
Zack