Analytics
2.1K members online now
2.1K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Google Analytics is not working after website transfer

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi there - I recently had my website transferred from IntroEyes.com (tracking code UA-81151744-1to IntroWellness.com (tracking code UA-93276933-1). Anyways, ever since the transfer (and after implementing a redirect) my google analytics has been very inaccurate. Would anyone be willing to take a look at my website code and see where I'm going wrong?

 

Thanks in advance! 

 

Ryan

1 Expert replyverified_user

Re: Google Analytics is not working after website transfer

Top Contributor
# 2
Top Contributor

Hi @Ryan C :-)

The tracking code for introeyes.com is still installed.

 

and there is an error with the tracking code for introwellness.com, in that it seems to be a modified and incomplete snippet (does not include the send pageview)

<!-- Ads on this site are served by WP PRO Advertising System - All In One Ad Manager v4.7.5 - wordpress-advertising.tunasite.com -->
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','wppas_ga');wppas_ga('create','UA-93276933-1','auto');

</script><!-- / WP PRO Advertising System - All In One Ad Manager. -->

 

wppas_ga('send','pageview'); seems to be missing from the above snippet.. 

should read as:

<!-- Ads on this site are served by WP PRO Advertising System - All In One Ad Manager v4.7.5 - wordpress-advertising.tunasite.com -->
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','wppas_ga');wppas_ga('create','UA-93276933-1','auto');wppas_ga('send','pageview');

</script><!-- / WP PRO Advertising System - All In One Ad Manager. -->

 

also need to ensure that the website url added to the Property Setting and View Setting pages do not have www added 

 

 

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Google Analytics is not working after website transfer

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Thanks for the feedback, Bronwyn V! I'm currently using the monster insights google analytics wordpress plugin. I uninstalled and reinstalled the plugin to see if it registered the updated tracking code (of which I don't think it did). Any other recommendations on how to address this problem? Thank you so much! - Ryan

Google Analytics is not working after website transfer

Top Contributor
# 4
Top Contributor

Did you clear the site cache using the caching plugin that is installed on the site to update the site/plugin changes?

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Google Analytics is not working after website transfer

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

I did not. Let me try that and I'll get back to you on if it worked Smiley Happy

 

You're the best! 

 

Thanks, 

Ryan

Google Analytics is not working after website transfer

Top Contributor
# 6
Top Contributor

I'm a bit confused with the tracking setup


IntroEyes.com (tracking code UA-81151744-1) is still installed.

Then two copies of code are installed for IntroWellness.com (tracking code UA-93276933-1)
One via the monster insights google analytics that you mention
and then another by what appears to be WP PRO Advertising System - All In One Ad Manager v5.2.1 - wordpress-advertising.tunasite.com

Is there a reason the introeyes.com tracking is still installed?

 

and if the advertising system adds the tracking then seperate tracking installation via another seperate plugin for the same property id shouldnt be necessary

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Google Analytics is not working after website transfer

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

I removed the tracking code under the advertising plugin and made some modifications to remove the duplicate tracking codes. Hopefully this resolves the issue. Thank you so much for your help!!

 

Ryan

Re: Google Analytics is not working after website transfer

[ Edited ]
Top Contributor
# 8
Top Contributor

Hi @Ryan C

There still appears to be a copy of the tracking code in the head section not being added by the plugin

It's visable when checking the site source code via browser

<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-93276933-1','auto');ga('send','pageview');</script>

<noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head>

 

 introwellness.jpg

 

 

 

 

Bronwyn Vourtis, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here

Google Analytics is not working after website transfer

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

I think we FINALLY fixed it! Thank you so much for all your help! You've been amazing!!!