AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

Analytics
5.4K members online now
5.4K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Going from Enhanced to Regular Ecommerce

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

So, our company has a bit of an issue, I think.

 

A few months ago, we implemented the Google Analytics Enhanced Ecommerce, then, one of our programmers launched some pages with the Regular Google Analytics Ecommerce.  Since then, we haven't been able to get enhanced or the regular working.

 

I've tried taking all the Analytics code out completely and just use one or the other (as I know there is issues using both at the same time - the other guy didn't know) but can't get ANY data flowing

 

Page Views work, no ecommerce data Smiley Sad

 

Do I need to create a new property? new tracker object? not really sure whats up now...all the code is right from the Google Analytics Development page and was working, just not after they were used together.

Re: Going from Enhanced to Regular Ecommerce

Follower ✭ ☆ ☆
# 2
Follower ✭ ☆ ☆
Hi Adam,

A couple clarifications:
First, so do you want to stick to the Enhanced Ecommerce, or the Regular Ecommerce?
Second, was the Enhanced Ecommerce tracking working back then?
Third, how much time have you given GA to process data before the data makes to the report after making your tracking changes?
Fourth, is it correct to assume that you are using on-page code, and no tag management system is used?

Debugging suggestions:
Instead of making more edits, try rolling back the website code to prior state without the Regular Ecommerce codes.
Ensure the Enhanced Ecommerce code are working even back then.

Cheers,

Re: Going from Enhanced to Regular Ecommerce

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi David,

1) We will be sticking with the Regular Ecommerce.

2) It was, yes.

3) Plenty of time...a day.

4) on page code yes.

So at this point, I can get Page Views to work, but even when I remove all the ecommerce data and add it back a few days later, no ecommerce data is sent.

This may not make sense, but I'm thinking I've "corrupted' something in my property using both? would that even make sense or be possible?

I've waited about a month before posting here to take out any "stupid" mistakes...super weird huh?

Re: Going from Enhanced to Regular Ecommerce

Follower ✭ ☆ ☆
# 4
Follower ✭ ☆ ☆
Hey Adam,

1) k
2) k
3) k
4) k
5) no such thing as "stupid" mistakes. we are human after all.

You might have checked the following, but please do it again:
1) Double check that your GA interface, under "Ecommerce Settings" for the appropriate views has Ecommerce enabled, and Enhanced Ecommerce switched to "OFF".
2) Double check that Regular Ecommerce plugin is loaded; check in code for "ga('require', 'ecommerce');"
3) Double check that Enhanced Ecommerce plugin is removed; check in code that "ga('require', 'ec');" is removed
4) Check the plugin is loaded after tracker is created
5) If the above does not resolve, try sending a fake transaction to see if that gets through; you may direct this to a fake property ID.

Let me know if this resolves the issue.




Re: Going from Enhanced to Regular Ecommerce

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Hi David,

1) Yup enhanced is switched off
2) This is what we have on the site...nothing else
<script type="text/javascript">(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-xxxxxxxx-x', 'auto'); ga('require', 'ecommerce'); ga('send', 'pageview');</script>
3) yup, the ec plugin was removed
4) Looks like the tracker is created and pushed to analytics
5) did a fake transaction...things are sent, just nothing populating in ecommerce

still nothing Smiley Sad

Re: Going from Enhanced to Regular Ecommerce

Follower ✭ ☆ ☆
# 6
Follower ✭ ☆ ☆
Hi Adam,

Awesome.
Can you check your network traffic to verify that:
1) the transaction hit actually has transaction id
2) the transaction hit is going to the right property
3) I recommend literally copying and pasting one transaction item from Google Developers Guide to send to you QA property; ensures format is correct

Let me know how it goes.